MM编程俱乐部 (线段树)

MM编程俱乐部

ACM is popular in HDU. Many girls want to learn more about programming skills in ACM. As one of assistances of Lcy, Yifenfei is now busy preparing a new club called “MM Programming Club”. Of Course, He will be the leader of the club, and teach these girls patiently. After the news posted around the campus, as many as N girls are determined to take part in the club. However, the numbers of members are limited; Yifenfei will only select K of them. It is quite a difficult problem. Here is a list of all information about N girls. Each of them has intelligence value and prettiness value. He also wants these K members such that the difference of intelligence between any two of them must not be greater than MAXK (If K = 1, the difference is zero). Now he wants to maximize the Sum of these K girls’ prettiness value.

Input

Many test case, please process to end of file. Each test first contains three integers N(1 <= N <= 200), K(1 <= K <= N), MAXK(1 <= MAXK <= 500). Then N lines follow. Each line contains two integers S, T (1 <= S, T <= 500). S represents the intelligence value, and T represents the prettiness value.

Output

If he can’t succeed in selecting K girls, print “-1”. Otherwise, Print the maximum the Sum of these K girls’ prettiness value.

Sample Input

2 1 0
1 2
2 3
2 2 0
1 2
2 3
2 2 1
1 2
2 3

Sample Output

3
-1
5

题目的大概意思是在n个女孩中取k个女孩在满足她们之间的智商差小于一个MAXK的情况下,使她们的颜值和最大。
前面第一眼看到就是DFS+剪枝,时间复杂度是O(n!)会TLE。
另一种是采取贪心的思想,将女孩按智商排序,然后遍历所有智商差为k的区间,区间按颜值后取前k个和sum,然后取所有区间的sum中最大的一个。这种方法的时间复杂度是O(n^2*logn)。

//由于本人比较懒
//这里贴出的是杨同学的代码
#include<iostream>
#include<cstring>
#include<cmath>
#include<vector>
#include<algorithm>
#define mst(a,b) memset(a,b,sizeof(a))
using namespace std;
const int maxn=10000+5;
struct node{
    int w,v;
}stu[maxn];
bool cmp1(node x,node y)
{
    return x.w<y.w;
}
bool cmp2(node x,node y)
{
    return x.v>y.v;
}
int n,k,limit,res,ans;
int main()
{
    ios::sync_with_stdio(false);
    cin.tie(0);
    while(cin>>n>>k>>limit)
    {
        res=-1;
        for(int i=1;i<=n;i++)
        cin>>stu[i].w>>stu[i].v;
        sort(stu+1,stu+n+1,cmp1);
        for(int i=1;i<=n;i++)
        {
            ans=stu[i].v;
            int w=stu[i].w;
            vector<node> tmp;
            for(int j=i+1;stu[j].w-w<=limit&&j<=n;j++)
                tmp.push_back(stu[j]);
            if(tmp.size()<k-1) continue;
            sort(tmp.begin(),tmp.end(),cmp2);
            for(int m=0;m<k-1;m++)
                ans+=tmp[m].v;
            res=max(res,ans);
        }
        cout<<res<<endl;
    }
    return 0;
}

第三种方法是用线段树维护,建一颗(1,T)的的线段树,维护区间内的女孩个数与颜值和,先将所有女孩按智商排序,然后遍历更新到线段树中去,如果树中人数等于k或者是智商差值大于MAXK,一个个减去最左边的女孩直到满足要求,取所有当树中人数等于k的颜值和,也就是MAX{tree[1].sum}。首先一次排序的时间复杂度是nlogn,后面的遍历每次树的更新操作是logT,时间复杂度是nlogT,由于T>n所以总的时间复杂度就是nlogT。

#include<cstdio>
#include<algorithm>
#include<iostream>
using namespace std;
struct node{
    int s,t;
    bool operator < (const node & e) const {
            return s<e.s;
        }
};
struct seg{
    int l,r,mid;
    int s;
    int num;
};
seg tree[505<<2];
node n_[205];
int ri;
void build(int k,int l,int r){
    tree[k].l=l;
    tree[k].r=r;
    tree[k].mid=(l+r)>>1;
    tree[k].s=tree[k].num=0;
    if(l==r)return;
    build(k<<1,l,tree[k].mid);
    build(k<<1|1,tree[k].mid+1,r);
}
void pushup(int k){
    tree[k].s=tree[k<<1].s+tree[k<<1|1].s;
}
void add(int k,int x){
    tree[k].num++;
    if(tree[k].l==tree[k].r){
        tree[k].s+=x;
        return;
    }
    if(x<=tree[k].mid)add(k<<1,x);
    else add(k<<1|1,x);
    pushup(k);
}
void sub(int k,int x){
    tree[k].num--;
    if(tree[k].l==tree[k].r){
        tree[k].s-=x;
        return;
    }
    if(x<=tree[k].mid)sub(k<<1,x);
    else sub(k<<1|1,x);
    pushup(k);
}
int sum(int k,int x){
   
    if(!x)return 0;
    if(tree[k].l==tree[k].r){
        return x*tree[k].l;
    }
    if(x<=tree[k<<1|1].num)return sum(k<<1|1,x);
    else return sum(k<<1,x-tree[k<<1|1].num)+tree[k<<1|1].s;
}
int main(){
    int n,k,d;
    while (scanf("%d%d%d",&n,&k,&d)!=EOF){
       for(int i=1;i<=n;i++){
          scanf("%d%d",&n_[i].s,&n_[i].t);
       }
       sort(n_+1,n_+1+n);
        ri=1;
        build(1,1,500);
        int res=-1;
        for(int i=1;i<=n;i++){
            add(1,n_[i].t);
            while (ri<=i&&n_[i].s-n_[ri].s>d){
                sub(1,n_[ri].t);
                ri++;
            }
            if(tree[1].num>=k){
                res=max(res,sum(1,k));
            }
        }
        printf("%d\n",res);
    }
}

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,590评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 86,808评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 151,151评论 0 337
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,779评论 1 277
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,773评论 5 367
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,656评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,022评论 3 398
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,678评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 41,038评论 1 299
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,659评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,756评论 1 330
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,411评论 4 321
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,005评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,973评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,203评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,053评论 2 350
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,495评论 2 343