题目:
Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ's farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow. Line 1 of each farm: Three space-separated integers respectively: N, M, and W Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path. Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output "YES" if FJ can achieve his goal, otherwise output "NO" (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time. For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题目是说有一个图,图上有n个点,m条边,还有w个虫洞。
每条边都有一个起点和一个终点,并且有所需的时间(权值),而每个虫洞的权值在题中实际上是负数(时光倒流)。问此人通过此图能否回到过去(实际上就是问此图有没有负圈)。
由于涉及到负圈,因此Dijkstra算法变失效。因此此题可以采用Bellman-Ford算法。
如果图中不存在从某点可达的负圈,那么最短路不会经过同一个顶点2次(最多通过顶点个数-1条边),外循环最多执行顶点个数-1次。
注意:普通路线是双边,虫洞路线是单边,还有可能一条路既是普通路线又是虫洞。
参考代码:
#include <iostream>
#include <cstring>
#define INF 999999
#define N 35000
using namespace std;
struct edge {
int from,to,cost;
};
edge es[N];
int d[N];
bool shorter(int n,int m,int count) {
memset(d,0,sizeof(d));
d[1] = 0;
for (int j = 1;j <= n;++j) {
for (int i = 0;i < count;++i) {
edge e = es[i];
if (d[e.to] > d[e.from] + e.cost) {
d[e.to] = d[e.from] + e.cost;
if (j == n) return true;
}
}
}
return false;
}
int main() {
int n,m,w;//n:V,m:E,w:W;
int t;
cin >> t;
while (t--) {
memset(es,INF,sizeof(es));
cin >> n >> m >> w;
int i,j,k;
int count = 0;
for (i = 0;i < m;++i) {
cin >> es[i].from >> es[i].to >> es[i].cost;
}
for (j = 0;j < w;++j) {
cin >> es[i+j].from >> es[i+j].to >> es[i+j].cost;
es[i+j].cost = -es[i+j].cost;
}
for (k = 0;k < m;++k) {
es[i+j+k].from = es[k].to;
es[i+j+k].to = es[k].from;
//cout << es[k].cost << endl;
if (es[i+j+k].cost>=INF) {
es[i+j+k].cost = es[k].cost;
}
}
count = count + i + j + k;
if(shorter(n,m,count)) {
cout << "YES" << endl;
}
else {
cout << "NO" << endl;
}
}
return 0;
}