题目详情
1135 Is It A Red-Black Tree (30 分)
There is a kind of balanced binary search tree named red-black tree in the data structure. It has the following 5 properties:
- (1) Every node is either red or black.
- (2) The root is black.
- (3) Every leaf (NULL) is black.
- (4) If a node is red, then both its children are black.
- (5) For each node, all simple paths from the node to descendant leaves contain the same number of black nodes.
For example, the tree in Figure 1 is a red-black tree, while the ones in Figure 2 and 3 are not.
||
| :-: | :-: | :-: |
| Figure 1 | Figure 2 | Figure 3 |
For each given binary search tree, you are supposed to tell if it is a legal red-black tree.
Input Specification:
Each input file contains several test cases. The first line gives a positive integer K (≤30) which is the total number of cases. For each case, the first line gives a positive integer N (≤30), the total number of nodes in the binary tree. The second line gives the preorder traversal sequence of the tree. While all the keys in a tree are positive integers, we use negative signs to represent red nodes. All the numbers in a line are separated by a space. The sample input cases correspond to the trees shown in Figure 1, 2 and 3.
Output Specification:
For each test case, print in a line "Yes" if the given tree is a red-black tree, or "No" if not.
Sample Input:
3
9
7 -2 1 5 -4 -11 8 14 -15
9
11 -2 1 -7 5 -4 8 14 -15
8
10 -7 5 -6 8 15 -11 17
Sample Output:
Yes
No
No
代码(c++)
参考自https://www.liuchuo.net/archives/4099
直接将前序遍历序列依次按照二叉搜索树的插入方法插入空树中即可得到原树。
建树后需要判断1.每个红色节点的左右节点是否为黑色节点。2.每个节点的左右子树所含的黑色节点数是否相同。3.根节点是否为黑色。
#include <iostream>
#include <cmath>
using namespace std;
int K, N, pre[35];
struct node{
int val;
node *left, *right;
};
node* build(node* root, int val){ //建树
if(root == NULL){
root = (node*)malloc(sizeof(struct node));
root->val = val;
root->left = NULL;
root->right = NULL;
}else if(abs(val) > abs(root->val))root->right = build(root->right, val);
else root->left = build(root->left, val);
return root;
}
bool isRedBlack(node* tree){ //判断红色节点的左右节点是否为黑色
if(tree == NULL)return true;
if(tree->val < 0){
if(tree->left != NULL && tree->left->val < 0)return false;
if(tree->right != NULL && tree->right->val < 0)return false;
}
return isRedBlack(tree->left) && isRedBlack(tree->right);
}
int getNum(node* tree){ //计算子树的黑色节点数
if(tree == NULL)return 0;
int l = getNum(tree->left);
int r = getNum(tree->right);
return (tree->val > 0) ? max(l, r) + 1 : max(l, r); //当节点颜色为黑色时加1
}
bool judge(node* tree){ //判断左右子树所含的黑色节点数是否相同
if(tree == NULL)return true;
int l = getNum(tree->left);
int r = getNum(tree->right);
if(l != r)return false;
return judge(tree->left) && judge(tree->right);
}
int main(){
scanf("%d", &K);
for(int i = 0; i < K; i++){
node* tree = NULL;
scanf("%d", &N);
for(int i = 0; i < N; i++){
scanf("%d", &pre[i]);
tree = build(tree, pre[i]); //直接按照前序遍历的顺序插入
}
if(pre[0] < 0 || !isRedBlack(tree) || !judge(tree))printf("No\n");
else printf("Yes\n");
}
return 0;
}