AC-captive-portal+本地认证

AC(config)#vlan 10;20;101
AC(config)#
AC(config)#interface vlan 10
AC(config-if-vlan10)#
AC(config-if-vlan10)#ip address 10.80.0.254 255.255.255.0
AC(config-if-vlan10)#    
AC(config-if-vlan20)#Interface Vlan20
AC(config-if-vlan20)#ip address 10.80.1.62 255.255.255.192 
AC(config-if-vlan20)#
AC(config-if-vlan20)#interface vlan 101                   
AC(config-if-vlan101)#
AC(config-if-vlan101)#ip address 10.80.1.66 255.255.255.252
AC(config-if-vlan101)#
AC(config-if-vlan101)#exi
AC(config)#
AC(config)#service dhcp
AC(config)#ip dhcp pool vlan10     
AC(dhcp-vlan10-config)#network-address 10.80.0.0 255.255.255.0
AC(dhcp-vlan10-config)#default-router 10.80.0.254 
AC(dhcp-vlan10-config)#exi
AC(config)#ip dhcp pool vlan20                    
AC(dhcp-vlan20-config)#network-address 10.80.1.0 255.255.255.192
AC(dhcp-vlan20-config)#default-router 10.80.1.62                
AC(dhcp-vlan20-config)#exi
AC(config)#ip dhcp pool vlan101                         
AC(dhcp-vlan101-config)#network-address 10.80.1.64 255.255.255.252
AC(dhcp-vlan101-config)#default-router 10.80.1.66 
AC(dhcp-vlan101-config)#exit 
AC(config)#interface ethernet 1/0/21
AC(config-if-ethernet1/0/21)#switchport mode trunk 
AC(config-if-ethernet1/0/21)#switchport trunk native vlan 101
AC(config-if-ethernet1/0/21)#exi

#等待1分钟
AC(config)#sh ip dhcp binding
Total dhcp binding items: 1, the matched: 1
IP address          Hardware address         Lease expiration         Type
10.80.1.65          00-03-0F-99-7E-E0        Mon Jan 02 00:17:00 2006 Dynamic

AC#ping 10.80.1.65
Type ^c to abort.
Sending 5 56-byte ICMP Echos to 10.80.1.65, timeout is 2 seconds.
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/0/0 ms
AC#


AC#sh wireless ap status

    MAC Address                                                            Configuration                
 (*) Peer Managed  IP Address                              Profile Status     Status           Age      
------------------ --------------------------------------- ------- ------- ------------- --------------
 00-03-0f-99-7e-e0 10.80.1.65                              1       Auth    Not Config    0d:00:00:01

Total Access Points............................ 1

AC#
AC#sh wireless ap status

    MAC Address                                                            Configuration                
 (*) Peer Managed  IP Address                              Profile Status     Status           Age      
------------------ --------------------------------------- ------- ------- ------------- --------------
 00-03-0f-99-7e-e0 10.80.1.65                              1       Managed Success       0d:00:00:01

Total Access Points............................ 1



AC(config)#sh wireless ap status 

    MAC Address                                                            Configuration                
 (*) Peer Managed  IP Address                              Profile Status     Status           Age      
------------------ --------------------------------------- ------- ------- ------------- --------------
 00-03-0f-99-7e-e0 10.80.1.65                              1       Managed Success       0d:00:00:03

Total Access Points............................ 1
AC(config)#
AC(config)#
AC(config)#
AC(config)#sh wireless ap 00-03-0f-99-7e-e0  status

MAC address.................................... 00-03-0f-99-7e-e0
Location....................................... 
IP Address..................................... 10.80.1.65
IP Subnet Mask................................. 255.255.255.252
IPv6 Address................................... -----
IPv6 Prefix.................................... -----
Managing Switch................................ Local Switch
Switch MAC Address............................. 00-03-0f-bd-01-ec
Switch IP Address.............................. 10.80.1.66
Status......................................... Managed
Last Disconnect Time and reason................ 0d:00:00:00  None
Configuration Status........................... Success
Last Failing Configuration Element............. None
Configuration Failure Error.................... 
Debug Mode..................................... Disable
Code Download Status........................... Not Started
Reset Status................................... Not Started
Profile........................................ 1 - Default
Vendor ID...................................... Digital China (Shanghai) Networks Ltd.
Protocol Version............................... 2
Software Version............................... 3.3.2.31
Hardware Version............................... 2.0.1
Uboot Version.................................. 1.0.6
Hardware Type.................................. 59 - WL8200-I2(R2), Indoor Dual Radio a/n/ac, b/g/n
Serial Number.................................. WL020420I824000455
Discovery Reason............................... Switch IP Configured
Authenticated Clients.......................... 0
System Up Time................................. 0d:00:10:16
Online Time.................................... 0d:00:07:20
Age............................................ 0d:00:00:00
CPU Type....................................... AR9563-775
CPU Usage(5s).................................. 13%
CPU Usage(30s)................................. 14%
CPU Usage(5min)................................ 14%
Memory Size Total(KB).......................... 126124
Memory Size Used(KB)........................... 82820
Static primary DNS Server...................... Not Configured
Static backup DNS Server....................... Not Configured
Management Vlan................................ 1
Management Vlan Priority....................... 0
Native Vlan.................................... 1

AC(config)#


!!!必须配置!!!

wireless
 enable
 no auto-ip-assign
 ap authentication none
 discovery vlan-list 101
 mac-authentication-mode black-list
 static-ip  10.80.1.66


AC(config)#wireless
AC(config-wireless)#network 1
AC(config-network)#ssid 2022skills-2.4G
AC(config-network)#vlan 10
AC(config-network)#security mode wpa-personal
AC(config-network)#wpa key skills01
AC(config-network)#exit
AC(config-wireless)#network 20
AC(config-network)#ssid 2022skills-5G
AC(config-network)#vlan 20
AC(config-network)#hide-ssid
AC(config-network)#security mode none


================

AC(config-wireless)#ap profile 1
AC(config-ap-profile)#
AC(config-ap-profile)#radio 1
AC(config-ap-profile-radio)#vap 0
AC(config-ap-profile-vap)#network 1
AC(config-ap-profile-vap)#enable 
AC(config-ap-profile-vap)#exi
AC(config-ap-profile-radio)#
AC(config-ap-profile-radio)#vap 1
AC(config-ap-profile-vap)#network 2     这里还没创建先打上去        
AC(config-ap-profile-vap)#enable 
AC(config-ap-profile-vap)#exi
AC(config-ap-profile-radio)#exi
AC(config-ap-profile)#radio 2
AC(config-ap-profile-radio)#vap 15                
AC(config-ap-profile-vap)#network 20
AC(config-ap-profile-vap)#enable 
AC(config-ap-profile-vap)#exi
AC(config-ap-profile-radio)#exi
AC(config-ap-profile)#


AC#wireless ap profile apply 1   下发配置


AC(config)#vlan 21   
AC(config-vlan21)#
AC(config-vlan21)#interface vlan 21
AC(config-if-vlan21)#ipv6 address 2001:10:81::1/112
AC(config-if-vlan21)#exi
AC(config)#ipv6 enable


AC(config)#service dhcpv6 
AC(config)#

AC(config)#ipv6  dhcp pool vlan21
AC(dhcpv6-vlan21-config)#network-address 2001:10:81::1 112
AC(dhcpv6-vlan21-config)#excluded-address 200:10:81::1
AC(dhcpv6-vlan21-config)#option 52 ipv6 2001:10:81::1
AC(dhcpv6-vlan21-config)#exi

AC(config)#interface vlan 21
AC(config-if-vlan21)#ipv6 dhcp server vlan21      
AC(config-if-vlan21)#ipv6 nd managed-config-flag 
AC(config-if-vlan21)#ipv6 nd other-config-flag 
AC(config-if-vlan21)#
AC(config-if-vlan21)#exi


AC(config-wireless)#network 2
AC(config-network)#ssid 2022skills_IPv6
AC(config-network)# security mode wpa-personal 
AC(config-network)#wpa key skills01
AC(config-network)#vlan 21



AC(config)#captive-portal 
AC(config-cp)#enable
AC(config-cp)#authentication-type internal 
AC(config-cp)#user GUEST
AC(config-cp-local-user)#password 123456
AC(config-cp-local-user)#group test1
AC(config-cp-local-user)#exi
    
AC(config-cp)#configuration 1
AC(config-cp-instance)#enable 
AC(config-cp-instance)#verification local 
AC(config-cp-instance)#group test1
AC(config-cp-instance)#protocol http 
AC(config-cp-instance)#interface ws-network 1
AC(config-cp-instance)#exi

AC(config)#  
AC#wireless ap profile apply 1
All configurations will be send to the aps associated to this profile and associated clients on these aps will be disconnected. Are you sure you want to apply the profile configuration? [Y/N] y
AP Profile apply is in progress.
AC#


AC(config)#wireless 
AC(config-wireless)#sh wireless ap status 

    MAC Address                                                            Configuration                
 (*) Peer Managed  IP Address                              Profile Status     Status           Age      
------------------ --------------------------------------- ------- ------- ------------- --------------
 00-03-0f-99-7e-e0 10.80.1.65                              1       Managed Success       0d:00:00:05

Total Access Points............................ 1
AC(config-wireless)#ap database 00-03-0f-99-7e-e0
AC(config-ap)#radio 1 power 90
AC(config-ap)#radio 2 power 90


mac-authentication-mode black-list
known-client 80-45-DD-77-CC-48 action global-action

 network 1
  mac authentication local

AC#wireless ap profile apply 1


在老版本设备中就直接生效了,
然后连上2.4Gwifi去10.80.0.254去认证就行了

认证通过后就可以正常通信了~~~

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 203,456评论 5 477
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 85,370评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 150,337评论 0 337
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,583评论 1 273
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,596评论 5 365
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,572评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,936评论 3 395
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,595评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,850评论 1 297
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,601评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,685评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,371评论 4 318
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,951评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,934评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,167评论 1 259
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 43,636评论 2 349
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,411评论 2 342