ASCII码排序
Input
输入数据有多组,每组占一行,有三个字符组成,之间无空格。
Output
对于每组输入数据,输出一行,字符中间用一个空格分开。
Sample Input
qwe
asd
zxc
Sample Output
e q w
a d s
c x z
程序分析
通过ASCLL码值比较,确定大小。需注意”可无限次输入“。
AC程序如下:
//hdu-2000
#include<iostream>
using namespace std;
int main()
{
int t;
char a, b, c;
while(cin>>a>>b>>c)
{
if (a > b)
{
t = a;
a = b;
b = t;
}
if (a > c)
{
t = a;
a = c;
c = t;
}
if (b > c)
{
t = b;
b = c;
c = t;
}
cout << a << ' ' << b << ' ' << c << endl;
}
return 0;
}