PAT Advanced 1022. Digital Library (30) (C语言实现)

我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容(本篇文章链接)。此处文章目前已更新至与Github Pages同步。欢迎star我的repo

题目

A Digital Library contains millions of books, stored according to their
titles, authors, key words of their abstracts, publishers, and published
years. Each book is assigned an unique 7-digit number as its ID. Given any
query from a reader, you are supposed to output the resulting books, sorted in
increasing order of their ID's.

Input Specification:

Each input file contains one test case. For each case, the first line contains
a positive integer N ( \le 10^4 ) which is the total number of books. Then
N blocks follow, each contains the information of a book in 6 lines:

  • Line #1: the 7-digit ID number;
  • Line #2: the book title -- a string of no more than 80 characters;
  • Line #3: the author -- a string of no more than 80 characters;
  • Line #4: the key words -- each word is a string of no more than 10 characters without any white space, and the keywords are separated by exactly one space;
  • Line #5: the publisher -- a string of no more than 80 characters;
  • Line #6: the published year -- a 4-digit number which is in the range [1000, 3000].

It is assumed that each book belongs to one author only, and contains no more
than 5 key words; there are no more than 1000 distinct key words in total; and
there are no more than 1000 distinct publishers.

After the book information, there is a line containing a positive integer M
( \le 1000 ) which is the number of user's search queries. Then M lines
follow, each in one of the formats shown below:

  • 1: a book title
  • 2: name of an author
  • 3: a key word
  • 4: name of a publisher
  • 5: a 4-digit number representing the year

Output Specification:

For each query, first print the original query in a line, then output the
resulting book ID's in increasing order, each occupying a line. If no book is
found, print Not Found instead.

Sample Input:

3
1111111
The Testing Book
Yue Chen
test code debug sort keywords
ZUCS Print
2011
3333333
Another Testing Book
Yue Chen
test code sort keywords
ZUCS Print2
2012
2222222
The Testing Book
CYLL
keywords debug book
ZUCS Print2
2011
6
1: The Testing Book
2: Yue Chen
3: keywords
4: ZUCS Print
5: 2011
3: blablabla

Sample Output:

1: The Testing Book
1111111
2222222
2: Yue Chen
1111111
3333333
3: keywords
1111111
2222222
3333333
4: ZUCS Print
1111111
5: 2011
1111111
2222222
3: blablabla
Not Found

思路

数据的存储与查询。

使用了最简单暴力的结构数组来存储,然后简单地按照ID排下序,遍历数组核对就行了。

这样写是很简单的,如果要使用复杂的数据结构肯定会更快。

作为参考:最后一个测试点用了660毫秒,上限为1200。

代码

最新代码@github,欢迎交流

#include <stdio.h>
#include <stdlib.h>
#include <string.h>

typedef struct book {
    int ID;
    char title[81];
    char author[81];
    char keywords[5][11];
    char publisher[81];
    int year;
} Book;

int cmpbyid(const void *a, const void *b)
{
    return (*(Book**)a)->ID - (*(Book**)b)->ID;
}

int main()
{
    int N, M, count, query_type, query_year;
    char space, query_str[81];
    Book books[10000] = {0}, *p, *booksbyid[10000];

    scanf("%d", &N);
    for(int i = 0; i < N; i++)
    {
        p = booksbyid[i] = books + i;
        scanf("%d%c", &p->ID, &space);
        scanf("%[^\n]%c", p->title, &space);
        scanf("%[^\n]%c", p->author, &space);
        space = '\0';
        for(int k = 0; space != '\n'; k++)
            scanf("%s%c", p->keywords[k], &space);
        scanf("%[^\n]%c", p->publisher, &space);
        scanf("%d", &p->year);
    }

    qsort(booksbyid, N, sizeof(Book*), cmpbyid);

    scanf("%d", &M);
    for(int i = 0; i < M; i ++)
    {
        count = 0;
        scanf("%d: %[^\n]%c", &query_type, query_str, &space);
        printf("%d: %s\n", query_type, query_str);
        for(int j = 0; j < N; j++)
        {
            p = booksbyid[j];
            switch(query_type)
            {
                case 1:
                    if(strcmp(query_str, p->title) == 0)
                    {
                        printf("%07d\n", p->ID);
                        count ++;
                    }
                    break;
                case 2:
                    if(strcmp(query_str, p->author) == 0)
                    {
                        printf("%07d\n", p->ID);
                        count ++;
                    }
                    break;
                case 3:
                    for(int k = 0; k < 5; k ++)
                        if(strcmp(query_str, p->keywords[k]) == 0)
                        {
                            printf("%07d\n", p->ID);
                            count ++;
                        }
                    break;
                case 4:
                    if(strcmp(query_str, p->publisher) == 0)
                    {
                        printf("%07d\n", p->ID);
                        count ++;
                    }
                    break;
                case 5:
                    sscanf(query_str, "%d", &query_year);
                    if(query_year == p->year)
                    {
                        printf("%07d\n", p->ID);
                        count ++;
                    }
                    break;
                default:
                    break;
            }
        }
        if(count == 0) puts("Not Found");
    }

    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 194,088评论 5 459
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 81,715评论 2 371
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 141,361评论 0 319
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,099评论 1 263
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 60,987评论 4 355
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,063评论 1 272
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,486评论 3 381
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,175评论 0 253
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,440评论 1 290
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,518评论 2 309
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,305评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,190评论 3 312
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,550评论 3 298
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,880评论 0 17
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,152评论 1 250
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,451评论 2 341
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,637评论 2 335

推荐阅读更多精彩内容

  • pyspark.sql模块 模块上下文 Spark SQL和DataFrames的重要类: pyspark.sql...
    mpro阅读 9,422评论 0 13
  • Cyber-dojo.org是编程操练者的乐园。下面是这个网站上的43个编程操练题目,供编程操练爱好者参考。 10...
    程序员吾真本阅读 1,850评论 1 2
  • 先生的读者,主动靠近为多,多被先生博学而吸引,三两句就掉几本书,先生用字、辞藻、造境、皆恰然为之,自成高峰,与人格...
    徐子为阅读 210评论 0 2
  • 在一个东南小镇,一户普通的人家,虽然已是深更半夜,但是这家却灯火通明。不时的传来女人声嘶力竭的叫声。突然一阵婴儿的...
    89e5fe9e43d5阅读 537评论 0 2
  • 最近住的地方底下的大门经常出现设备连接问题,导致常被锁在门外进不了大门。 例如像现在又被锁在外面了...
    坚持_6阅读 366评论 0 2