sicily_1176 Two Ends

题目

Constraints

Time Limit: 1 secs, Memory Limit: 64 MB

Description

In the two-player game "Two Ends", an even number of cards is laid out in a row. On each card, face up, is written a positive integer. Players take turns removing a card from either end of the row and placing the card in their pile. The player whose cards add up to the highest number wins the game. Now one strategy is to simply pick the card at the end that is the largest -- we'll call this the greedy strategy. However, this is not always optimal, as the following example shows: (The first player would win if she would first pick the 3 instead of the 4.)
3 2 10 4
You are to determine exactly how bad the greedy strategy is for different games when the second player uses it but the first player is free to use any strategy she wishes.

Input

There will be multiple test cases. Each test case will be contained on one line. Each line will start with an even integer n followed by n positive integers. A value of n = 0 indicates end of input. You may assume that n is no more than 1000. Furthermore, you may assume that the sum of the numbers in the list does not exceed 1,000,000.

Output

For each test case you should print one line of output of the form:
In game m, the greedy strategy might lose by as many as p points.
where m is the number of the game (starting at game 1) and p is the maximum possible difference between the first player's score and second player's score when the second player uses the greedy strategy. When employing the greedy strategy, always take the larger end. If there is a tie, remove the left end.

Sample Input

4 3 2 10 4
8 1 2 3 4 5 6 7 8
8 2 2 1 5 3 8 7 3
0

Sample Output

In game 1, the greedy strategy might lose by as many as 7 points.
In game 2, the greedy strategy might lose by as many as 4 points.
In game 3, the greedy strategy might lose by as many as 5 points.

思路

目标是在后手总是使用贪心策略的情况下,让先手赢,并且计算赢了多少分数。也就是说,先手每一步都要取得最优策略,需要用到动态规划。
而动态规划也有Top-Down DP+记忆化搜索和bottom-up DP两种思路,本文使用的是第一种(引入每个过程的最优取法的结果)

代码

// Copyright (c) 2015 HuangJunjie@SYSU(SNO:13331087). All Rights Reserved.
// sicily_1176 Two Ends: http://soj.sysu.edu.cn/1176
#include <cstdio>
#include <cstring>

#define MAX_SIZE 1000

// global variables.
int cards[MAX_SIZE + 1];  // abandons cards[0].

// two dimension array used to record the best strategy answer in part of the
// sequence.
int states[MAX_SIZE + 1][MAX_SIZE + 1];


// Top-down DP refering http://www.cnblogs.com/joyeecheung/p/3995682.html.
// considers your opposite are the second guy and always use the Greedy 
// stratege, but the you want to win him, so you should find the best way 
// to win him.
//
// @Param left: the left card remains
// @Param right: the right crad remains
// @return: the score that you can win.
int dp(int left, int right) {
  // the final cards is taken away by your opposite
  if (left > right) return 0;

  // only the final card you can choose.
  if (left == right) return cards[left];

  // if the best strategy has not been analyzed, analyzed it.
  // you are A, your opposite is B.
  if (states[left][right] == -1) {
    // considers taking either side's card
    int takeLeft = 0, takeRight = 0;

    // if the left side is taken, which will B take.
    // here has a question that two different operator '>' and '>=' will cause
    // difference answers. The reson why is still being cosidered
    if (cards[right] > cards[left+1]) {
      takeLeft = dp(left + 1, right - 1) + cards[left];
    } else {
      takeLeft = dp(left + 2, right) + cards[left];
    }

    // if the right side is taken, which will B take.
    // here has a question that two different operator '>' and '>=' will cause
    // difference answers. The reson why is still being cosidered
    if (cards[left] >= cards[right-1]) {
      takeRight = dp(left + 1, right - 1) + cards[right];
    } else {
      takeRight = dp(left, right-2) + cards[right];
    }

    // get the better strategy.
    states[left][right] = takeLeft > takeRight ? takeLeft : takeRight;
  }

  return states[left][right];
}
int main() {
  int n;
  for (int game = 1; scanf("%d", &n) != EOF && n; game++) {
    // reset the global variables to avoid miscalculation.
    memset(cards, -1, sizeof(cards));
    memset(states, -1, sizeof(states));
    int sum = 0;
    for (int i = 1; i <= n; i++) {
      scanf("%d", &cards[i]);
      sum += cards[i];
    }

    int sumA = dp(1, n);
    int sumB = sum - sumA;
    printf("In game %d, the greedy strategy might lose by as many as %d points.\n",
           game, sumA - sumB);
  }
  return 0;
}

参考

http://www.cnblogs.com/joyeecheung/p/3995682.html

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 206,482评论 6 481
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 88,377评论 2 382
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 152,762评论 0 342
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 55,273评论 1 279
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 64,289评论 5 373
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 49,046评论 1 285
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,351评论 3 400
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,988评论 0 259
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 43,476评论 1 300
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,948评论 2 324
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,064评论 1 333
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,712评论 4 323
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,261评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,264评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,486评论 1 262
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,511评论 2 354
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,802评论 2 345

推荐阅读更多精彩内容