1087 All Roads Lead to Rome(dijkstra+dfs)

1087 All Roads Lead to Rome (30 分)

Indeed there are many different tourist routes from our city to Rome. You are supposed to find your clients the route with the least cost while gaining the most happiness.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2≤N≤200), the number of cities, and K, the total number of routes between pairs of cities; followed by the name of the starting city. The next N−1 lines each gives the name of a city and an integer that represents the happiness one can gain from that city, except the starting city. Then K lines follow, each describes a route between two cities in the format City1 City2 Cost. Here the name of a city is a string of 3 capital English letters, and the destination is always ROM which represents Rome.

Output Specification:

For each test case, we are supposed to find the route with the least cost. If such a route is not unique, the one with the maximum happiness will be recommanded. If such a route is still not unique, then we output the one with the maximum average happiness -- it is guaranteed by the judge that such a solution exists and is unique.
Hence in the first line of output, you must print 4 numbers: the number of different routes with the least cost, the cost, the happiness, and the average happiness (take the integer part only) of the recommanded route. Then in the next line, you are supposed to print the route in the format City1->City2->...->ROM.

Sample Input:

6 7 HZH
ROM 100
PKN 40
GDN 55
PRS 95
BLN 80
ROM GDN 1
BLN ROM 1
HZH PKN 1
PRS ROM 2
BLN HZH 2
PKN GDN 1
HZH PRS 1

Sample Output:

3 3 195 97
HZH->PRS->ROM

题目大意

有N个城市K条边,每条边的权重称为cost,每个点的权重为happiness,输入文件给定源城市,求从源城市到目标城市ROM的最短路径,若最短路径不唯一,则选择happiness最大的路径,若这个路径依然不唯一,则选择平均happiness最大的路径,输出最短路径的条数,最短路径长度,推荐路径的happiness和对应的平均happiness

分析

先通过dijkstra算法求出最短路径,用二维数组保存,然后用dfs求最短路径上的happiness,平均happiness,开始时将平均happiness设为int型,结果有一个测试点报「段错误」,最后将平均happiness设定为double类型,代码AC~~,通过查询PAT错误说明,段错误是由指针越界或者因递归层次过深导致堆栈溢出引起,依然没理解为什么改变平均happiness后段错误消失。

#include <iostream>
#include <map>
#include <vector>
using namespace std;
int happiness[210];
vector<vector<int> >a;
vector<vector<int> > path;
map<string,int> mp;
map<int,string> ansmp;
int n,k;
string city;
int rome;
int maxhap=-1;
double max_avr_hap=-1.0;
const int inf=999999;
void dfs(int u,vector<int> &tmppath,vector<int> &finalpath,int &route_num){
    tmppath.push_back(u);
    if(u==rome){
        route_num++;
        int sumhap=0;
        double avr_hap=0.0;
        for(int i=0;i<tmppath.size();i++){
            sumhap+=happiness[tmppath[i]];
        }
        avr_hap=1.0*sumhap/(tmppath.size()-1);
        if(sumhap>maxhap){
            maxhap=sumhap,max_avr_hap=avr_hap;
            finalpath=tmppath;
        }else if(sumhap==maxhap && avr_hap>max_avr_hap){
            maxhap=sumhap,max_avr_hap=avr_hap;
            finalpath=tmppath;
        }
    }else{
        for(int w=0;w<path[u].size();w++){
            dfs(path[u][w],tmppath,finalpath,route_num);
        }
    }
    tmppath.pop_back();
}
void shortpath(int u){
    vector<int> dis(n,inf);
    vector<bool> visit(n,false);
    dis[u]=0;
    for(int k=0;k<n;k++){
        int t=-1,mindis=inf;
        for(int i=0;i<n;i++){
            if(visit[i]==false && dis[i]<mindis){
                t=i;
                mindis=dis[i];
            }
        }
        if(t==-1) break;
        visit[t]=true;
        for(int v=0;v<n;v++){
            if(visit[v]==false){
                if(dis[v]>dis[t]+a[v][t]){
                    path[v].clear();
                    path[v].push_back(t);
                    dis[v]=dis[t]+a[v][t];
                }else if(dis[v]==dis[t]+a[v][t]){
                    path[v].push_back(t);
                }
            }
        }
    }
}
int main(){
    cin>>n>>k>>city;
    a.resize(n),path.resize(n);
    fill(a.begin(),a.end(),vector<int>(n,999));
    mp[city]=0,ansmp[0]=city;
    for(int i=1;i<n;i++){
        string s;
        int val;
        cin>>s>>val;
        mp[s]=i,ansmp[i]=s;
        happiness[i]=val;
        if(s=="ROM"){
            rome=i;
        }
    }
    for(int i=0;i<k;i++){
        string s1,s2;
        int val;
        cin>>s1>>s2>>val;
        a[mp[s1]][mp[s2]]=a[mp[s2]][mp[s1]]=val;
    }
    shortpath(rome);
    int route_num=0,mincost=0;
    vector<int> tmppath,finalpath;
    dfs(0,tmppath,finalpath,route_num);
    
    for(int i=0;i<finalpath.size()-1;i++) {
        // printf("finalpath=%d\n",finalpath[i] );
        mincost+=a[finalpath[i]][finalpath[i+1]];
    }
    printf("%d %d %d %d\n",route_num,mincost,maxhap,(int)max_avr_hap );
    for(int i=0;i<finalpath.size();i++){
        if(i==0) cout<<ansmp[finalpath[i]];
        else cout<<"->"<<ansmp[finalpath[i]];
    }
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,053评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 85,527评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 150,779评论 0 337
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,685评论 1 276
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,699评论 5 366
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,609评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,989评论 3 396
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,654评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,890评论 1 298
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,634评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,716评论 1 330
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,394评论 4 319
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,976评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,950评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,191评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 44,849评论 2 349
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,458评论 2 342

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,283评论 0 10
  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,363评论 0 23
  • 每天更新太累了,我一直追求写的量,没有保持好文章的质,要放慢写作的速度,把质量提上去,我写完1000多字就想往专题...
    华客鲁俊阅读 234评论 2 8
  • 9.1 《》阴谋者 命运稳准的开了第二枪 混乱不堪 接着 死神的号角 是不是也会吹响 不过阴谋者的游戏罢了 我只是...
    玛诺奇朵的爱情阅读 196评论 0 1
  • 充实的日子过得特别快,一转眼又过了一个月。在这一个月里,我尽最大的努力做好自己的每一份工作,除了支持和陪伴,我想我...
    某小沁阅读 401评论 2 4