1097 Deduplication on a Linked List (25 分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​ ) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.
Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4
​​ , and Next is the position of the next node.

Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

分析

  • 结构体数组存储第一遍读的链表,下标即地址
  • 根据起始地址遍历一遍链表,01数组p标志key值的绝对值是否出现过,两种情况分别push到vk和vr向量中
  • 遍历一遍vk,vr输出两个链表

code

#include <iostream>
#include <vector>
#include <cmath>
using namespace std;

struct node{
    int ad,key,next;
}Node[100000];

int p[10001];
vector<node> vk,vr;

int main()
{
    int start,n;
    scanf("%d %d",&start,&n);
    int a,b,c;
    for(int i=0;i<n;i++){
        scanf("%d%d%d",&a,&b,&c);
        Node[a] = {a,b,c};
    }
    for(int i=start;i!=-1;i=Node[i].next){
        if(p[abs(Node[i].key)]==1){
            vr.push_back(Node[i]);
        }else{
            p[abs(Node[i].key)]=1;
            vk.push_back(Node[i]);
        }
    }
    for(int i=0;i<vk.size();i++){
        if(i==0){
            printf("%05d %d",vk[i].ad,vk[i].key);
        } else {
            printf(" %05d\n%05d %d",vk[i].ad,vk[i].ad,vk[i].key);
        }
        if(i==vk.size()-1){
            printf(" -1\n");
        }
    }

     for(int i=0;i<vr.size();i++){
        if(i==0){
            printf("%05d %d",vr[i].ad,vr[i].key);
        } else {
            printf(" %05d\n%05d %d",vr[i].ad,vr[i].ad,vr[i].key);
        }
        if(i==vr.size()-1){
            printf(" -1\n");
        }
    }
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 196,200评论 5 462
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 82,526评论 2 373
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 143,321评论 0 325
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,601评论 1 267
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 61,446评论 5 358
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,345评论 1 273
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,753评论 3 387
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,405评论 0 255
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,712评论 1 294
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,743评论 2 314
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,529评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,369评论 3 315
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,770评论 3 300
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,026评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,301评论 1 251
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,732评论 2 342
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,927评论 2 336

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,260评论 0 10
  • 下面是贾谊写的《过秦论》。当作本文的概述,再合适不过。在司马迁的《史记·秦始皇本纪 》中引用全文引用!一字不落!史...
    EasyChill阅读 1,037评论 4 4
  • 在日料店见到了童年的小伙伴。 掐指一算,上一次见面应该是在24年前。 姑娘现在非常出色,经营着自己的珠宝店,在国外...
    迷糊的谜阅读 260评论 0 0
  • 2017年11月18日 星期六 晴冷(80) 今天早餐我们在外面吃的,从楼上下来的时候还真冷啊,天上还时不时飘来几...
    大野芳菲阅读 170评论 0 0
  • 这种东西,面试问的人很多,但是基本答案都是用队列组,用栅栏什么的 这种,最lowB的方法就是自己写个变量,每次请求...
    蒋昉霖阅读 426评论 1 2