MacOS Chrome 删除 anysearch 恶意软件

电脑安装了 MplayerX,莫名地浏览器就被劫持了,长达一年之久,后面 Safari 更新限制了第三方插件的使用,这里只针对Chrome,打开 Chrome 扩展里面会多出来 Anysearch 的插件。由于对 Mac 系统不是很熟悉,不知道自启动是如何管理的,直到上个星期才找到彻底删除的方案。

保存代码为:

#/usr/bin/bash

killall taskgated
killall finder

# anysearch will hijack browser default search engine
# this script will delete it from firefox and chrome
# run this script by: 
# sudo ~/anysearch.sh

echo Deleting "/Library/LaunchDaemons/com.SearchFunctionDaemon.plist" ...
rm -rf "/Library/LaunchDaemons/com.SearchFunctionDaemon.plist"

echo Deleting "~/Library/LaunchAgents/com.SearchFunction.plist" 
rm -rf "~/Library/LaunchAgents/com.SearchFunction.plist"

# Seachfunction is a executable applications
echo Deleting "/Library/Application Support/com.SearchFunctionDaemon/SearchFunction" ...
rm -rf "/Library/Application Support/com.SearchFunctionDaemon/SearchFunction"

echo Deleting "/Library/Application Support/com.SearchFunctionDaemon/" ...
rm -rf -d "/Library/Application Support/com.SearchFunctionDaemon/"

echo Deleting "/Library/LaunchAgents/com.SearchFunction.plist" ...
rm -rf "/Library/LaunchAgents/com.SearchFunction.plist"

echo Deleting "/Library/Managed Preferences/$USER/com.google.Chrome.plist" ...
rm -rf "/Library/Managed Preferences/$USER/com.google.Chrome.plist"

echo Deleting "/Library/Managed Preferences/$USER/complete.plist" ...
rm -rf "/Library/Managed Preferences/$USER/complete.plist"
id=$(profiles -P | gsed -n '1s/.*Function//gp')

echo Deleting direcory $id ...
cd "/Users/$USER/Library/Application Support/Google/Chrome/Default/Extensions/"
rm -rf '$id'

profiles -D -f ".com.crx.SearchFunction$id"

# remove firefox  default
cd "/Users/qinfengbin/Library/Application Support/Firefox/Profiles"
rm -rf -d .*
# after delete  re-install firefox

手动的方法

首先,涉及到如下路径:

"/Library/LaunchAgents"
"/Library/LaunchDaemons"
"/Users/$USER/Library/Application Support/Google/Chrome/Default/Extensions"
"/Library/Managed Preferences/$USER"
"/Library/Application Support/com.SearchFunctionDaemon"
"~/Library/LaunchAgents"
"/Library/LaunchAgents"
"/Library/LaunchDaemons"
"/System/Library/LaunchAgents"
"/System/Library/LaunchDaemons"

关闭进程并查看 Chrome 的profiles

先进入 Activity Monitor 搜索 any、search、function 等关键字,强制退出进程。

  1. 打开 Chrome ,地址栏输入:chrome://policy,如果发现 ExtensionSettings 不为空,且等级为 Mandatory 则说明浏览器被劫持:
level = Mandatory,说明浏览器被劫持
{
   "chromeMetadata": {
      "OS": "macOS Version 10.14.6 (Build 18G95)",
      "application": "Google Chrome",
      "revision": "201e747d032611c5f2785cae06e894cf85be7f8a-refs/branch-heads/3865@{#776}",
      "version": "77.0.3865.75 (Official Build) (64-bit)"
   },
   "chromePolicies": {
      "ExtensionSettings": {
         "level": "mandatory",
         "scope": "machine",
         "source": "platform",
         "value": {
            "ffkjcnnfloopcaibchbfbommdncnilpe": {
               "installation_mode": "allowed",
               "update_url": "https://clients2.google.com/service/update2/crx"
            }
         }
      }
   },
   "extensionPolicies": {
      "ghbmnnjooekpmoecnnnilnnbdlolhkhi": {

      },
      "gighmmpiobklfepjocnamgkkbiglidom": {

      }
   }
}

上面的profiles也可以在 system preferences - profiles 中看到。

  1. 删除: /Library/LaunchDaemons/com.SearchFunctionDaemon.plist 其内容:
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
    <key>Label</key>
    <string>com.SearchFunctionDaemon</string>
    <key>ProgramArguments</key>
    <array>
        <string>/Library/Application Support/com.SearchFunctionDaemon/SearchFunction</string>
        <string>r</string>
    </array>
    <key>RunAtLoad</key>
    <true/>
    <key>StartInterval</key>
    <integer>14400</integer>
</dict>
</plist>

它指向了一个另外一个文件夹的执行文件,也就是恶意软件本身,即:/Library/Application Support/com.SearchFunctionDaemon,到路径里直接删除该文件夹和里面的 SearchFunction 恶意软件。

所以必须删除 /Library/Application Support/com.SearchFunctionDaemon/SearchFunction 如果删除不干净SearchFunction 可能死灰复燃。

  1. 到路径:~/Library/LaunchAgents,删除 anysearch 相关的文件

  2. 删除
    System/Library/PrivateFrameworks/SafariShared.framework/Versions/A/XPCServices/com.apple.Safari.SearchHelper.xpc/Contents/MacOS/com.apple.Safari.SearchHelper

  3. 最恶心的莫过于软件居然把自己伪装成Profile
    打开 System Preferences ——Profiles,删除 SearchFunction

Profiles
  1. 用 Terminal 打开路径:/Library/Managed Preferences/$USER ,执行如下命令:
sudo -s

/usr/libexec/PlistBuddy -c \
"Delete :com.google.Chrome" \
complete.plist

/usr/libexec/PlistBuddy -c \
"Delete :com.google.Chrome" \
com.google.Chrome.plist
  1. 删除 firefox 的配置文件,到路径:/Users/qinfengbin/Library/Application Support/Firefox/Profiles 删除下面的所有的文件。同时重新安装 firefox。

2020-06-12 更新

DTrace 跟踪软件运行

sudo opensnoop  | grep SearchFunction
_______________________________________________
    0    125 taskgated      3 /Users/xxx/Library/Application Support/com.SearchFunction
    0    125 taskgated      3 /Users/xxx/Library/Application Support/com.SearchFunction
    0    125 taskgated      3 /Users/xxx/Library/Application Support/com.SearchFunction/SearchFunction
  501  21866 SearchFunction   3 /dev/dtracehelper
  501  21866 SearchFunction  -1 /etc/.mens_debug

列表太长不一一列出来,opensnopp 比较直观,可以看到软件通过什么系统调用,访问了什么数据。

如果安装有多个浏览器,软件可以安插到任意浏览器的子目录,因此使用

最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,189评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 85,577评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 150,857评论 0 337
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,703评论 1 276
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,705评论 5 366
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,620评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,995评论 3 396
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,656评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,898评论 1 298
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,639评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,720评论 1 330
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,395评论 4 319
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,982评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,953评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,195评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 44,907评论 2 349
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,472评论 2 342

推荐阅读更多精彩内容