POJ 1244 Slots of Fun

POJ 1244 Slots of Fun

The International Betting Machine company has just issued a new type of slot machine. The machine display consists of a set of identical circles placed in a triangular shape. An example with four rows is shown below. When the player pulls the lever, the machine places a random letter in the center of each circle. The machine pays off whenever any set of identical letters form the vertices of an equilateral triangle. In the example below, the letters 'a' and 'c' satisfy this condition.

样例图片

In order to prevent too many payoffs, the electronics in the machine ensures that no more than 3 of any letter will appear in any display configuration.
IBM is manufacturing several models of this machine, with varying number of rows in the display, and they are having trouble writing code to identify winning configurations. Your job is to write that code.

Input

Input will consist of multiple problem instances. Each instance will start with an integer n indicating the number of rows in the display. The next line will contain n(n + 1)/2 letters of the alphabet (all lowercase) which are to be stored in the display row-wise, starting from the top. For example, the display above would be specified as
4
abccddadca
The value of n will be between 1 and 12, inclusive. A line with a single 0 will terminate input.

Output   

For each problem instance, output all letters which form equilateral triangles on a single line, in alphabetical order. If no such letters exist, output "LOOOOOOOOSER!".

Sample Input

4
abccddadca
6
azdefccrhijrrmznzocpq
2
abc
0

Sample Output

ac
crz
LOOOOOOOOSER!

题目的大意就是要判断输入中字母相同且构成等边三角形三点的字母有哪些,
等边三角形等边三角形,就是三边相等就行了,数据也小,直接暴力就行,最主要的问题是求两点间的距离,这里可以把整个三角形就是一个60°的斜坐标系,推一下斜坐标系两点距离就可以了


坐标系.png

\ |\vec{ab}|=|\vec{a}-\vec{b}|=\sqrt{( (x_1-x2_1)\vec{e_1}+(y_1-y2_1)\vec{e_2})^2}
\quad\quad =\sqrt{(x_1-x_2)^2+(y_1-y_2)^2-(x_1-x_2)(y_1-y_2)}

然后到这里就把ab的距离求出来了,直接暴力判断三点距离相等就行了

#include<iostream>
#include<cstring>
using namespace std;
char record[13][13];
int zmnum[26];
int zm[26][4][2];
int result[26];
int getdis(int x1,int x2,int y1,int y2){
    return (x2-x1)*(x2-x1)+(y2-y1)*(y2-y1)-(x2-x1)*(y2-y1);
}
int main(){
    int n;
    while(cin>>n&&n){
        memset(result,0,sizeof(result));
        memset(zm,0,sizeof(zm));
        memset(zmnum,0,sizeof(zmnum));
        for(int i=0;i<n;i++){
            for(int j=0;j<=i;j++){
                cin>>record[i][j];
            }
        }
        if(n==1){
            cout<<"LOOOOOOOOSER!"<<endl;
            continue;
        }
        double layer=((n+1)*n)/2;
         for(int i=0;i<n;i++){
            for(int j=0;j<=i;j++){
                char c=record[i][j];
                zm[c-'a'][zmnum[c-'a']][0]=i;
                zm[c-'a'][zmnum[c-'a']++][1]=j;
            }
        }
        bool loser=true;
        for(int i=0;i<26;i++){
            char c=i+'a';
            if(zmnum[i]<3)continue;
            int l1=getdis(zm[i][0][0],zm[i][1][0],zm[i][0][1],zm[i][1][1]);
            int l2=getdis(zm[i][1][0],zm[i][2][0],zm[i][1][1],zm[i][2][1]);
            int l3=getdis(zm[i][2][0],zm[i][0][0],zm[i][2][1],zm[i][0][1]);
            if(l1==l2&&l2==l3)loser=false,cout<<c;
        }
        if(loser)cout<<"LOOOOOOOOSER!";
        cout<<endl;
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,590评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 86,808评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 151,151评论 0 337
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,779评论 1 277
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,773评论 5 367
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,656评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,022评论 3 398
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,678评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 41,038评论 1 299
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,659评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,756评论 1 330
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,411评论 4 321
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,005评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,973评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,203评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,053评论 2 350
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,495评论 2 343

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,285评论 0 10
  • **2014真题Directions:Read the following text. Choose the be...
    又是夜半惊坐起阅读 9,369评论 0 23
  • The Inner Game of Tennis W Timothy Gallwey Jonathan Cape ...
    网事_79a3阅读 11,688评论 2 19
  • 这两天,我们一群人来湖南考心理咨询师,昨天上午刚考试结束。我们最初8个人一起的,现在只剩下我们三个人在长沙玩了。 ...
    爱笑的女孩运气好阅读 224评论 0 1
  • 儿子十岁了,前天刚过的生日,他很高兴又激动,导致头天晚上晚睡着一个多小时,为什么会这么激动呢,我是没有这样的体验,...
    屰月阅读 336评论 1 4