题目:
Problem Description
NanoApe, the Retired Dog, has returned back to prepare for for the National Higher Education Entrance Examination!In math class, NanoApe picked up sequences once again. He wrote down a sequence with n
numbers and a number m
on the paper.Now he wants to know the number of continous subsequences of the sequence in such a manner that the k
-th largest number in the subsequence is no less than m
.Note : The length of the subsequence must be no less than k
.Input
The first line of the input contains an integer T
, denoting the number of test cases.In each test case, the first line of the input contains three integers n,m,k
.The second line of the input contains n
integers A1,A2,...,An
, denoting the elements of the sequence.1≤T≤10, 2≤n≤200000, 1≤k≤n/2, 1≤m,Ai≤10^9
Output
For each test case, print a line with one integer, denoting the answer.
Sample Input
1
7 4 2
4 2 7 7 6 5 1
Sample Output
18
中文:
问题描述
退役狗 NanoApe 滚回去学文化课啦!在数学课上,NanoApe 心痒痒又玩起了数列。他在纸上随便写了一个长度为 n的数列,他又根据心情写下了一个数 m。他想知道这个数列中有多少个区间里的第 k大的数不小于 m当然首先这个区间必须至少要有 k个数啦。
bestcoder官方给出的解法(尺取法):
将不小于m的数看作1,剩下的数看作0,那么只要区间内1的个数不小于k则可行,枚举左端点,右端点可以通过two-pointer求出。时间复杂度O(n)。
参考代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
typedef long long ll;
const int N = 200000+10;
ll a[N];
int n,m;
ll k;
void init() {
memset(a,0,sizeof(a));
}
void input() {
for (int i = 0;i < n;++i) {
scanf("%lld", &a[i]);
if (a[i] >= m) a[i] = 1;
else a[i] = 0;
}
}
ll chiqu() {
ll ans = 0;
int l = 0,w = 0;
ll sum = 0;
while (1) {
while (w < n && sum < k) {
sum += a[w];
++w;
}
if (sum < k) break;
ans += n - (w-1);//如果当前情况符合条件,则加上之后的区间也符合;
//cout << ans << endl;
sum -= a[l];
++l;
}
return ans;
}
int main() {
int t;
scanf("%d", &t);
while (t--) {
scanf("%d%d%d", &n, &m, &k);
init();
input();
ll ans = chiqu();
printf("%lld\n", ans);
}
return 0;
}