题目信息 1108. Finding Average (20)
The basic task is simple: given N real numbers, you are supposed to calculate their average. But what makes it complicated is that some of the input numbers might not be legal. A "legal" input is a real number in [-1000, 1000] and is accurate up to no more than 2 decimal places. When you calculate the average, those illegal numbers must not be counted in.Input Specification:Each input file contains one test case. For each case, the first line gives a positive integer N (<=100). Then N numbers are given in the next line, separated by one space.
Output Specification:For each illegal input number, print in a line "ERROR: X is not a legal number" where X is the input. Then finally print in a line the result: "The average of K numbers is Y" where K is the number of legal inputs and Y is their average, accurate to 2 decimal places. In case the average cannot be calculated, output "Undefined" instead of Y. In case K is only 1, output "The average of 1 number is Y" instead.Sample Input 1:75 -3.2 aaa 9999 2.3.4 7.123 2.35Sample Output 1:ERROR: aaa is not a legal numberERROR: 9999 is not a legal numberERROR: 2.3.4 is not a legal numberERROR: 7.123 is not a legal numberThe average of 3 numbers is 1.38Sample Input 2:2aaa -9999Sample Output 2:ERROR: aaa is not a legal numberERROR: -9999 is not a legal numberThe average of 0 numbers is Undefined
我的代码
#include <iostream>
#include <vector>
#include <iomanip>
#include <string>
#include <exception>
using namespace std;
bool preCheck(string a)//预处理函数
{
int count=0;
int c=0;
for(int i=0;i<a.size();++i)
{
if(a.at(i)=='.')//检验2.3.4这样的输入
++count;
if(count>=1)//检测decimal places>2的情况
++c; }
if(count>1)
return false; if(c>3) return false;
return true;
}
int main()
{
int count;
int size=0;
double sum=0;
double itmp=0;
cin>>count;
string *tmp=new string[count];
vector<string> out;
for(int i=0;i<count;i++)
{
cin>>tmp[i];
try {
if(!preCheck(tmp[i]))//由于stod()能转化2.3.4这样的数,所以进行了预处理
throw exception();
itmp=stod(tmp[i]);
if(itmp>1000||itmp<-1000)//题目要求
throw exception();
++size;
sum+=itmp;
}catch(exception &e)//由于stod转化失败后会发出异常,所以统一将不正确的输入进行异常处理
{
out.push_back(tmp[i]);
}
}
for(int i=0;i<count-size;i++)
{
cout<<"ERROR: "<<out.at(i)<<" is not a legal number"<<endl;
}
if(size!=0) {
sum=sum/size;
if(size==1)
cout<<fixed<<setprecision(2)<<"The average of "<<size<<" number is "<<sum<<endl;
else
cout<<fixed<<setprecision(2)<<"The average of "<<size<<" numbers is "<<sum<<endl; }
else { cout<<"The average of 0 numbers is Undefined"<<endl; }
return 0;
}
遇到的问题
- 如何将string转化为double
- 3.这样的输入是正确的
- 只有一个正常输入时,此时的输出是number