时间与收益

Description

Given a set of n jobs where each job i has a deadline and profit associated to it. Each job takes 1 unit of time to complete and only one job can be scheduled at a time. We earn the profit if and only if the job is completed by its deadline. The task is to find the maximum profit and the number of jobs done.

Input

The first line contains an integer T denoting the number of test cases. For each test case, the first line contains two integer n & p denoting the number of houses and number of pipes respectively. Next, p lines contain 3 integer inputs a, b & d, d denoting the diameter of the pipe from the house a to house b.Constraints:1<=T<=50,1<=n<=20,1<=p<=50,1<=a, b<=20,1<=d<=100

Output

For each test case, the output is the number of pairs of tanks and taps installed i.e n followed by n lines that contain three integers: house number of tank, house number of tap and the minimum diameter of pipe between them.

Sample Input
1
9 6
7 4 98
5 9 72
4 6 10
2 8 22
9 7 17
3 1 66
Sample Output
3
2 8 22
3 1 66
5 6 10

思路

贪心

我们可以先看最晚一个任务完成的时间T,从T开始往前推

  1. 在T时刻选一个任务ddl大于等于T,且profit最大的任务,完成这个任务,然后从任务列表中移除它
  2. 接着在T-1时刻选取任务ddl大于等于T-1,且profix最大的任务...
  3. 知道任务列表为空,或者T为0时结束

为什么在T时刻选择ddl大于等于T,profit最大的任务呢?

因为这是最后一个时刻,在这个时刻选择可以完成的价值最大的任务,不会影响到ddl大于等于T的任务,因为它们还可以在T之前的时刻完成,更不会影响到ddl在T之前的任务。所以按时间逆推,选取当前时间可以完成的价值最大的任务。

python(O(tn), t是最晚的时间,n是任务数量)
def solve(tasks):
    times = max([job[1] for job in tasks])
    count, profit = 0, 0
    tasks = set(tasks)
    for t in range(1, times+1)[::-1]:
        cur = None
        # 可以完成的,价值最大的任务
        for task in tasks:
            if task[1] >= t and (not cur or cur[2] < task[2]):
                cur = task
        if cur:
            count += 1
            profit += cur[2]
            tasks.remove(cur)

        if not tasks:
            break
    return count, profit

for _ in range(int(input())):
    input()
    nums = list(map(int, input().split()))
    jobs = [tuple(nums[i:i+3]) for i in range(0, len(nums), 3)]
    print(*solve(jobs))

上面找价值最大的任务时间复杂度是O(n), 使用堆,可以优化成O(logn)

python(O(tlogn))
import heapq, collections
def solve(tasks):
    times = max([job[1] for job in tasks])

    t_tasks = collections.defaultdict(list)
    for task in tasks:
        t_tasks[task[1]].append(task)

    count, profit, q = 0, 0, []
    for t in range(1, times+1)[::-1]:
        for task in t_tasks[t]:
            heapq.heappush(q, -task[2])
        if q:
            count += 1
            profit += -heapq.heappop(q)

    return count, profit


for _ in range(int(input())):
    input()
    nums = list(map(int, input().split()))
    jobs = [tuple(nums[i:i+3]) for i in range(0, len(nums), 3)]
    print(*solve(jobs))
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,793评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 87,567评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 151,342评论 0 338
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,825评论 1 277
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,814评论 5 368
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,680评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,033评论 3 399
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,687评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 42,175评论 1 300
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,668评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,775评论 1 332
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,419评论 4 321
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,020评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,978评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,206评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,092评论 2 351
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,510评论 2 343

推荐阅读更多精彩内容