Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
分析:
题目要求先输入考场个数,再输入每个考场人数和各个考场的考生分数。最终输出所有学生的注册号、总排名、考场号、考场排名。
按考场读入学生信息后,立即计算考场排名。再对所有学生进行排序,输出最终结果。
C++:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn = 30010;
struct Student {
char id[15];
int score, loc, locRank, finalRank;//id,分数,考场号,考场排名,总排名
} stus[maxn];
bool cmp(Student a, Student b) {
if (a.score != b.score) {
return a.score > b.score;
} else {
return strcmp(a.id, b.id) < 0;
}
}
int main() {
int n, k, num = 0;
scanf("%d", &n);
for (int i = 1; i <= n; i++) {
scanf("%d", &k);
for (int j = 0; j < k; j++) {
scanf("%s %d", &stus[num].id, &stus[num].score);
stus[num].loc = i;
num++;
}
//考场内排名
sort(stus + num - k, stus + num, cmp);
stus[num - k].locRank = 1;
for (int j = num - k + 1; j < num; j++) {
if (stus[j].score == stus[j - 1].score) {
stus[j].locRank = stus[j - 1].locRank;
} else {
stus[j].locRank = j + 1 - (num - k);
}
}
}
sort(stus, stus + num, cmp);
stus[0].finalRank = 1;
for (int i = 1; i < num; i++) {
if (stus[i].score == stus[i - 1].score) {
stus[i].finalRank = stus[i - 1].finalRank;
} else {
stus[i].finalRank = i + 1;
}
}
printf("%d\n", num);
for (int i = 0; i < num; i++) {
printf("%s %d %d %d\n", stus[i].id, stus[i].finalRank, stus[i].loc, stus[i].locRank);
}
return 0;
}