2018 SCNUACM 校赛 D题: Escape from the maze

先附上题目描述:

题目描述
WWJ loves his girlfriend very much. Suppose one day he stuck in a maze and could not see his
girlfriend. The lost case upsets him so much. WWJ wants to escape the maze as soon as possible.
However, he is very sleepy due to the overnight work, so in a certain position, he will stop and take a
nap. To simplify this problem, the maze can be considered an N × M two-dimensional array while WWJ
starts at (0, 0) (upper left)and the exit is in (N − 1, M − 1) (lower right ). The elements in array are consist
of . , X and number T range from 1-9.
The following rules describe how WWJ moves in maze.

  1. He takes 1 minute to move from one position to another.
  2. He can only move in four directions (up, down, left, right) at each step.
  3. He cannt pass the position marked by X because it represents the walls.
  4. When he reaches the position with number T, he will fall asleep in the next T minutes.
    Can you write a program to help him calculate the least time he takes to escape from this maze?
    输入
    The input contains several test cases. Each test case starts with a line contains two numbers N and M
    (2 >≤ N ≤ 100; 2 ≤ M ≤ 100) which indicate the size of the maze. Then an N × M two-dimensional array
    follows, which describe the whole maze. The input is terminated by the end of file. More details in the
    Sample Input.
    输出
    For each test case, you should output the least time WWJ should take to escape from the maze.
    If WWJ cannot help himself, please output: 'God please help our poor wwj.' .
    样例输入
    5 6
    .XX.1.
    ..X.2.
    2...X.
    ...XX.
    XXXXX.
    5 6
    .XX...
    ..XX1.
    2...X.
    ...XX.
    XXXXX.
    样例输出
    13
    God please help our poor wwj.

看到Maze这个关键字眼很容易想到BFS求最短路(可能是Leosu最近写多了BFS,所以看什么都是BFS,捂脸),事实上还真是BFS,于是很容易套模板写出来,不过这里我们需要注意一个地方就是这里求的是最少时间,也就是每一个点不一定只遍历一遍!!!所以用bool visit[][]来判重是有问题的。我们仔细分析题目可以看出这道题有种背包问题的感觉,因为每个点都有一个对应的最短到达时间,所以我们联想到状态转移方程,每到一个点都判断到这个点的时间是否比当前点的最短时间少,是才继续走。所以我们可以利用int visit[][]来存每一个点的最小时间最后输出visit[N-1][M-1]点的时间即可。
话不多说(虽然已经说了不少。。),直接上AC代码:

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
#include <queue>
#include <stack>
#define tx (x+dx[i])
#define ty (y+dy[i])
#define MAXN (100+10)
using namespace std;
struct temp{
    int x;
    int y;
    int cnt;
}a,b,c;
char maze[MAXN][MAXN];
int visit[MAXN][MAXN];
int n,m,dx[] = {-1,1,0,0},dy[] = {0,0,-1,1};
queue<struct temp>q;

bool check(int x,int y){
    if(x>=0&&y>=0&&x<n&&y<m) return true;
    return false;
}

void BFS(){
    a.x = 0,a.y = 0,a.cnt = 0;
    q.push(a);
    while(!q.empty()){
        int x,y;
        a = q.front();
        x = a.x,y = a.y;
        for(int i = 0;i<4;i++){
            if(check(tx,ty)&&maze[tx][ty]!='X'){
                if(maze[tx][ty]=='.'){
                    b.cnt = a.cnt+1;
                }
                else{
                    b.cnt = a.cnt+(int)(maze[tx][ty]-'0')+1;
                }
                if(b.cnt>=visit[tx][ty])//****关键代码,进行判重,注意要>=因为只是>的话只要出现数据全是'.'的大图就会出现TLE(超时)
                    continue;
                b.x = tx,b.y = ty;
                visit[tx][ty] = b.cnt;
                q.push(b);
            }
        }
        q.pop();
    }
}

int main()
{
    //freopen("text.txt","r",stdin);
    while(cin>>n>>m){
        for(int i = 0;i<n;i++){
            scanf("%s",maze[i]);
            for(int j = 0;j<m;j++){
                visit[i][j] = 99999999;
            }
        }
        BFS();
        if(visit[n-1][m-1]!=99999999){
            printf("%d\n",visit[n-1][m-1]);
        }
        else{
            printf("God please help our poor wwj.\n");
        }
    }
    return 0;
}

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 205,386评论 6 479
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 87,939评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 151,851评论 0 341
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,953评论 1 278
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,971评论 5 369
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,784评论 1 283
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,126评论 3 399
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,765评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 43,148评论 1 300
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,744评论 2 323
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,858评论 1 333
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,479评论 4 322
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,080评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,053评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,278评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,245评论 2 352
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,590评论 2 343

推荐阅读更多精彩内容