1021 Deepest Root (25)(25 分)

1021 Deepest Root (25)(25 分)
A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:

5
1 2
1 3
1 4
2 5

Sample Output 1:

3
4
5

Sample Input 2:

5
1 3
1 4
2 5
3 4

Sample Output 2:

Error: 2 components

题意:
给出n个节点(1~n),并给出n-1个边,求图的连通分量。如果连通分量为1,则求图对应的树的最大深度对应的root,如果不唯一则按升序排列输出。

思路:
柳婼 の blog
1.先通过DFS判断图的连通分量个数。
2.任取一个顶点,DFS求得最高高度的结点们,然后从中任取一个结点,再做一个DFS求得最高高度的结点们,做一个并集得到最终结果。

题解:

#include<cstdio>
#include<vector>
#include<set>
using namespace std;
vector<vector<int>> mp;
bool isVisit[10010];
int maxHeight = 1;
vector<int> temp;
set<int> s;
void dfs(int node, int height) {
    if (height > maxHeight) {
        temp.clear();
        temp.push_back(node);
        maxHeight = height;
    }
    else if (height == maxHeight) { 
        temp.push_back(node);
    }
    isVisit[node] = true;
    for (int i = 0; i < mp[node].size(); i++) {
        if (isVisit[mp[node][i]] == false) {
            dfs(mp[node][i], height + 1);
        }
    }
}
int main() {
    int n;
    scanf("%d", &n);
    mp.resize(n + 1);
    int a, b;
    for (int i = 1; i < n; i++) {
        scanf("%d %d", &a, &b);
        mp[a].push_back(b);
        mp[b].push_back(a);
    }
    int cnt = 0;
    int s1;
    for (int i = 1; i <= n; i++) {
        if (isVisit[i] == false) {
            dfs(i, 1);
            //假设cnt为1,将temp中的值放入s中。
            //如果cnt>1,这些值虽然不对,但也没用上。
            if (i == 1) {
                if (temp.size() != 0) s1 = temp[0];
                for (int j = 0; j < temp.size(); j++) {
                    s.insert(temp[j]);
                }
            }
            cnt++;
        }
    }
    if (cnt >= 2) {
        printf("Error: %d components\n", cnt);
    }
    else {
        temp.clear();
        fill(isVisit, isVisit + 10010, false);
        dfs(s1, 1);
        for (int i = 0; i < temp.size(); i++) {
            s.insert(temp[i]);
        }
        for (set<int>::iterator it = s.begin(); it != s.end(); it++) {
            printf("%d\n", *it);
        }
    }
    return 0;
}
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 194,524评论 5 460
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 81,869评论 2 371
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 141,813评论 0 320
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,210评论 1 263
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 61,085评论 4 355
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,117评论 1 272
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,533评论 3 381
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,219评论 0 253
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,487评论 1 290
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,582评论 2 309
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,362评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,218评论 3 312
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,589评论 3 299
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,899评论 0 17
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,176评论 1 250
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,503评论 2 341
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,707评论 2 335

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,258评论 0 10
  • (零) “求求你,杀了我。” 我十八岁时度过的最后一天,我对我母亲说了这句话。 那时我们爆发了一次争吵,我瞪着她,...
    AliceLand阅读 524评论 0 0
  • 前段时间去了一次上海,在上班高峰期坐地铁的时候,挤在熙熙攘攘的人群里,那时的我看着每一张脸,我会在心理不住的好奇,...
    U塔阅读 375评论 0 1
  • 先来说说小何戈友,从不看徒步群,那天传说群要解散,一片骚动,我也是助力加速升温,不小心看青海自驾游,这完全是我计划...
    红糖二姐阅读 289评论 0 1
  • 刚刚的场景还有我脑子里回荡,这个女孩是推销?失恋?精神失常?孤独?还是什么? 我和男友在地铁口等专车,车还没来,我...
    景景三页阅读 161评论 0 0