我的PAT系列文章更新重心已移至Github,欢迎来看PAT题解的小伙伴请到Github Pages浏览最新内容。此处文章目前已更新至与Github Pages同步。欢迎star我的repo。
题目
The highest building in our city has only one elevator. A request list is made
up with positive numbers. The numbers denote at which floors the elevator
will stop, in specified order. It costs 6 seconds to move the elevator up one
floor, and 4 seconds to move down one floor. The elevator will stay for 5
seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill
the requests on the list. The elevator is on the 0th floor at the beginning
and does not have to return to the ground floor when the requests are
fulfilled.
Input Specification:
Each input file contains one test case. Each case contains a positive integer
, followed by positive numbers. All the numbers in the input are less
than 100.
Output Specification:
For each test case, print the total time on a single line.
Sample Input:
3 2 3 1
Sample Output:
41
思路
很简单的题目,注意最后停住了5秒的等待时间也要算在内(其实不注意反倒不会有问题)。
代码
最新代码@github,欢迎交流
#include <stdio.h>
int main()
{
int N, time, cur, pre;
scanf("%d", &N);
for(pre = 0, time = 0; N--; pre = cur)
{
scanf("%d", &cur);
if(cur > pre) time += (cur - pre) * 6 + 5;
else time += (pre - cur) * 4 + 5;
}
printf("%d", time);
return 0;
}