Description
定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<iostream>
#include<queue>
#include<stack>
#define MAX 5
//#define NUM MAX*MAX
using namespace std;
typedef struct Node {
int x;
int y;
} Node;
Node mov[4] = { {0,-1},{0,1},{-1,0},{1,0} };
int maze[MAX][MAX];
int step[MAX][MAX] = { 0 }; //所有点都还没有被访问过,到起点步数是0
Node st = { 0,0 }; //起始点
Node e = { 4,4 }; //终止点
void bfs()
{
queue<Node> que;
que.push(st);
step[0][0] = 1;
while (que.size())
{
Node n = que.front();
que.pop();
if (n.x == e.x&&n.y == e.y)
break;
for (int i = 0; i < 4; i++)
{
//cout << n.x << " " << n.y << endl;
int nx = n.x + mov[i].x;
int ny = n.y + mov[i].y;
//cout << nx << " " << ny << endl;
//移动过后的坐标还在范围内,并且这个点可以走(没有出界并且没有走过)
if (nx >= 0 && nx <= 4 && ny >= 0 && ny <= 4 && maze[nx][ny] != 1 && step[nx][ny] == 0)
{
Node next;
next.x = nx;
next.y = ny;
que.push(next);
step[nx][ny] = step[n.x][n.y] + 1;//记录这个点到起点的步数
// cout<< step[nx][ny] <<"dsaa" << endl;
}
}
}
queue<Node> q;
stack<Node> s;
q.push(e);
s.push(e);
while (q.size())
{
Node n = q.front();
q.pop();
if (n.x == st.x&&n.y == st.y)
break;
for (int i = 3; i >= 0; i--)
{
int nx = n.x + mov[i].x;
int ny = n.y + mov[i].y;
//移动过后的坐标还在范围内,并且这个点是路径上的点
if (nx >= 0 && nx <= 4 && ny >= 0 && ny <= 4 && step[nx][ny] == step[n.x][n.y] - 1)
{
Node next;
next.x = nx;
next.y = ny;
q.push(next);
s.push(next);
}
}
}
while (!s.empty())
{
Node n = s.top();
s.pop();
cout << "(" << n.x << ", " << n.y << ")" << endl;
}
}
int main()
{
for (int i = 0; i < 5; i++)
for (int j = 0; j < 5; j++)
{
cin >> maze[i][j];
}
bfs();
system("pause");
return 0;
}