题目
1001 A+B Format (20 分
Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).
Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −106≤a,b≤106. The numbers are separated by a space.
Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.
Sample Input:
-1000000 9
Sample Output:
-999,991
分析
水题,转换成字符串输出,考虑临界值为0的情况即可!
代码
#include<iostream>
#include<cmath>
#include<string>
using namespace std;
int main(){
int a,b;
cin>>a>>b;
int x=a+b;
if(x==0){
cout<<0<<endl;
return 0;
}
int flag=0,i=1;
string str="";
if(x<0) flag=1;
x = abs(x);
while (x>0) {
str = char(x%10+'0') + str ;
if(i%3==0 && x>=10)
str = ',' + str ;
x=x/10;
i++;
}
if(flag==1) str='-'+str;
cout<<str<<endl;
}