单词积累
clique 派系 小圈子
undirected graph 无向图
adjacent 邻近的,毗邻的 相连的(说明两个点直接有连接)
题目
A clique is a subset of vertices of an undirected graph such that every two distinct vertices in the clique are adjacent. A maximal clique is a clique that cannot be extended by including one more adjacent vertex. (Quoted from https://en.wikipedia.org/wiki/Clique_(graph_theory))
Now it is your job to judge if a given subset of vertices can form a maximal clique.
Input Specification:
Each input file contains one test case. For each case, the first line gives two positive integers Nv (≤ 200), the number of vertices in the graph, and Ne, the number of undirected edges. Then Ne lines follow, each gives a pair of vertices of an edge. The vertices are numbered from 1 to Nv.
After the graph, there is another positive integer M (≤ 100). Then M lines of query follow, each first gives a positive number K (≤ Nv), then followed by a sequence of K distinct vertices. All the numbers in a line are separated by a space.
Output Specification:
For each of the M queries, print in a line Yes
if the given subset of vertices can form a maximal clique; or if it is a clique but not a maximal clique, print Not Maximal
; or if it is not a clique at all, print Not a Clique
.
Sample Input:
8 10
5 6
7 8
6 4
3 6
4 5
2 3
8 2
2 7
5 3
3 4
6
4 5 4 3 6
3 2 8 7
2 2 3
1 1
3 4 3 6
3 3 2 1结尾无空行
Sample Output:
Yes
Yes
Yes
Yes
Not Maximal
Not a Clique结尾无空行
思路
按照题目的clique设定,暴力遍历即可。
代码
#include <bits/stdc++.h>
using namespace std;
const int maxn = 205;
int graph[maxn][maxn];
int main() {
int N, M;
cin>>N>>M;
int num1, num2;
for (int i = 0; i < M; i++) {
cin>>num1>>num2;
graph[num1][num2] = graph[num2][num1] = 1;
}
int cnt;
cin>>cnt;
while (cnt--) {
int len;
vector<int> vec;
cin>>len;
int num;
int flag1 = 0;
int flag2 = 0;
for (int i = 0; i < len; i++) {
cin>>num;
vec.push_back(num);
}
for (int i = 0; i < len; i++) {
for (int j = i + 1; j < len; j++) {
if (graph[vec[i]][vec[j]] != 1) {
flag1 = 1;
break;
}
}
}
if (flag1 == 0) {
for (int i = 1; i <= N; i++) {
int j;
for (j = 0; j < len; j++) {
if (graph[i][vec[j]] != 1) {
break;
}
}
if (j == len) {
flag2 = 1;
break;
}
}
}
if (flag2 == 1) cout<<"Not Maximal"<<endl;
else if (flag1 == 0 ) cout<<"Yes"<<endl;
else if (flag1 == 1) cout<<"Not a Clique"<<endl;
}
}