【栈模拟DFS】ZOJ_2615_Cells

Scientists are conducting research on the behavior of a newly discovered Agamic Cellular Microbe. This
special kind of microbe is capable of massively reproducing by itself in a short time. The lifetime of an
ACM consists of three phases:

  1. The infancy phase, which starts from its birth and lasts for approximately several seconds;
  2. The multiplication phase, in which one ACM can procreate up to 100 offspring in only several
    milliseconds;
  3. The mature phase, in which it remains inactive for the rest of its life.
    At the beginning of the experiment, a newborn, single cell of ACM, is put into a suitable cir-
    cumstance for its production. This cell, numbered as 0, starts to multiply and its descendants are
    numbered, starting from 1, according to their positions in the family hierarchy. During the experiment
    special equipment is used to record the numbers of the offspring generated by each of the ACM's. The
    experiment is stopped after a certain time period.
Paste_Image.png

The family tree of ACM's in the _rst case of sample input
Your task is to help the scientists to determine whether one ACM is an ancestor of another.

Input
Standard input will contain multiple test cases. The _rst line of the input is a single integer T (1 _
T _ 10) which is the number of test cases. T test cases follow, each preceded by a single blank line.
Each test case starts with a single integer N (1 _ N _ 300; 000) which is the number of ACM's
that have their descendants recorded. The following N integers (not necessarily on a same line), Ci
(0 _ i < N; 0 _ Ci _ 100), give the number of offspring of the i-th ACM. The next line contains an
integer M (1 _ M _ 1; 000; 000) which is the number of queries. M lines follow, each contains two
integers a and b, querying whether the a-th ACM is an ancestor of the b-th ACM.
The total number of ACM's may be greater than N, but would never exceed 20,000,000.

Output
Results should be directed to standard output. Start each case with `Case #:' on a single line, where
# is the case number starting from 1. Two consecutive cases should be separated by a single blank
line. No blank line should be produced after the last test case.
For each query, print either 'Yes' or 'No' on a single line, which is the answer to the query.

Sample Input
2
6
3 2 1 1 0 2
5
0 1
2 4
3 5
1 8
6 9
5
2 0 3 0 1
4
2 6
1 6
2 3
3 5

Sample Output
Case 1:
Yes
No
No
Yes
No
Case 2:
Yes
No
Yes
No

题意:
给一颗树,求两个节点是否存在父子关系。

思路:
由于数据量非常大,直接深搜绝对超时,最坏的情况下所有节点形成一条链,遍历一次就会超时。
这里使用栈模拟DFS过程,并记录每一个节点的进出栈时间。对于某一对存在父子关系的节点,一定有:父节点先子节点进栈,子节点先父节点出栈。模拟一遍DFS,判断即可。


#include<cstdio>
#include<cstring>
using namespace std;

const int maxn = 300000;
const int maxm = 20000000;
int buf[maxn + 10];
int child[maxn + 10];
int token[maxn + 10]; // 判断当前的子节点
struct Node {
    int in;
    int out;
}node[maxm + 10];

int st[maxm + 10]; // 数组模拟栈
int top;

void dfs(int n) {
    memset(token, 0, sizeof(token));
    int count = 0;
    top = 0;
    st[top] = 0; // 根节点入栈
    int cur;
    while (true) {
        // 大于等于n一定没有子节点,直接出栈
        if (st[top] >= n) {
            node[st[top]].out = count++;
            --top;
        }
        cur = child[st[top]] + token[st[top]];
        // 判断是否遍历结束
        if (token[st[top]] == buf[st[top]] && top == 0) {
            node[st[top]].out = count;
            break;
        }
        // 判断当前栈顶元素的子节点是否遍历结束,出栈
        else if (token[st[top]] == buf[st[top]]) {
            node[st[top]].out = count++;
            --top;
        }
        // 入栈
        else {
            ++token[st[top]];
            st[++top] = cur;
            node[st[top]].in = count++;
        }
    }
    return;
}

int main() {
    int T;
    scanf("%d", &T);
    int n, m, a, b;
    for (int tt = 1; tt <= T; ++tt) {
        if (tt != 1)
            printf("\n");
        int num = 1;
        printf("Case %d:\n", tt);
        scanf("%d", &n);
        for (int i = 0; i < n; ++i) {
            scanf("%d", buf + i);
            child[i] = num; // 记录起始儿子的编号
            num += buf[i];
        }
        dfs(n);
        scanf("%d", &m);
        for (int i = 0; i < m; ++i) {
            scanf("%d%d", &a, &b);
            if (a >= b || a >= n || node[a].in>node[b].in || node[a].out < node[b].out)
                printf("No\n");
            else
                printf("Yes\n");
        }
    }
    return 0;
}


最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 199,064评论 5 466
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 83,606评论 2 376
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 146,011评论 0 328
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 53,550评论 1 269
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 62,465评论 5 359
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 47,919评论 1 275
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,428评论 3 390
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,075评论 0 254
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,208评论 1 294
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,185评论 2 317
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,191评论 1 328
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,914评论 3 316
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,482评论 3 302
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,585评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,825评论 1 255
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,194评论 2 344
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 41,703评论 2 339

推荐阅读更多精彩内容