实验8-1-7 数组循环右移 (20 分)
1. 题目摘自
https://pintia.cn/problem-sets/13/problems/551
2. 题目内容
本题要求实现一个对数组进行循环右移的简单函数:一个数组a中存有n(>0)个整数,将每个整数循环向右移m(≥0)个位置,即将a中的数据由(a0a1⋯an)变换为(an-m⋯an-1a0a1⋯an-m-1(最后m个数循环移至最前面的m个位置)。
函数接口定义:
int ArrayShift( int a[], int n, int m );
其中a[]是用户传入的数组;n是数组的大小;m是右移的位数。函数ArrayShift须将循环右移后的数组仍然存在a[]中。
输入样例:
6 2
1 2 3 4 5 6
输出样例:
5 6 1 2 3 4
3. 源码参考
#include <iostream>
using namespace std;
#define MAXN 10
int ArrayShift( int a[], int n, int m );
int main()
{
int a[MAXN], n, m;
int i;
cin >> n >> m;
for ( i = 0; i < n; i++ )
{
cin >> a[i];
}
ArrayShift(a, n, m);
for ( i = 0; i < n; i++ )
{
if (i != 0)
{
cout << " ";
}
cout << a[i];
}
cout << endl;
return 0;
}
int ArrayShift( int a[], int n, int m )
{
int b[MAXN];
memcpy(b, a, sizeof(int) * MAXN);
for(int i = 0; i < n; i ++)
{
a[i] = b[(n - m + i) % n];
}
return 0;
}