PAT Basic Level 1054
本题的基本要求非常简单:给定N个实数,计算它们的平均值。但复杂的是有些输入数据可能是非法的。一个“合法”的输入是[-1000,1000]区间内的实数,
并且最多精确到小数点后2位。当你计算平均值的时候,不能把那些非法的数据算在内。
输入格式:
输入第一行给出正整数N(<=100)。随后一行给出N个实数,数字间以一个空格分隔。
输出格式:
对每个非法输入,在一行中输出“ERROR: X is not a legal number”,其中X是输入。最后在一行中输出结果:“The average of K numbers is Y”,
其中K是合法输入的个数,Y是它们的平均值,精确到小数点后2位。如果平均值无法计算,则用“Undefined”替换Y。如果K为1,则输出:
“The average of 1 number is Y”。
输入样例1:
7
5 -3.2 aaa 9999 2.3.4 7.123 2.35
输出样例1:
ERROR: aaa is not a legal number
ERROR: 9999 is not a legal number
ERROR: 2.3.4 is not a legal number
ERROR: 7.123 is not a legal number
The average of 3 numbers is 1.38
输入样例2:
2
aaa -9999
输出样例2:
ERROR: aaa is not a legal number
ERROR: -9999 is not a legal number
The average of 0 numbers is Undefined
需要注意的地方有:
1.测试点会检查1000和-1000的边界值
2.数字可以只以小数点结尾
3.数字前正负号只可有一个
4.不包含字母
可以使用正则表达式,也可以用Double.parseDouble()然后抛异常的方法。
方法一:
import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;
import java.util.StringTokenizer;
import java.util.regex.Pattern;
import java.util.regex.Matcher;
public class Main {
public static void main(String[] args) throws IOException {
BufferedReader br;
br = new BufferedReader(new InputStreamReader(System.in));
int N = Integer.valueOf(br.readLine());
String s = br.readLine();
br.close();
StringTokenizer st = new StringTokenizer(s);
String regex = "[+-]?(([1-9][0-9]{0,3})|0)(\\.\\d{2})?";
Pattern pattern = Pattern.compile(regex);
double count = 0;
int cnt=0;
String tmp = "";
while(st.hasMoreTokens()){
tmp = st.nextToken();
Matcher matcher = pattern.matcher(tmp);
if(matcher.matches()&&Float.valueOf(tmp)<=1000&&Float.valueOf(tmp)>=-1000){
cnt++;
count+=Double.valueOf(tmp);
}
else System.out.print("ERROR: "+tmp+" is not a legal number\n");
}
if(cnt==0) System.out.println("The average of 0 numbers is Undefined");
else if(cnt==1) System.out.println("The average of 1 number is "+String.format("%.2f",count));
else System.out.println("The average of "+cnt+" numbers is "+String.format("%.2f",count/cnt));
}
}
由Double.parseDouble()方法抛异常的写法如下:
import java.util.Scanner;
public class Main1054_2 {
public static void main(String[] args){
Scanner sc = new Scanner(System.in);
int N = sc.nextInt();
int cnt=0;
double count=0;
for(int i=0;i<N;i++){
String s = null;
double d=0;
try{
s = sc.next();
d = Double.parseDouble(s); //自动抛出非实数的异常
double x = Double.parseDouble(String.format("%.2f",d));
if(d>1000 || d<-1000||Math.abs(x-d)>=0.001){ //带小数点超过两位数或者未在[-1000,1000]范围则手动抛异常
throw new NumberFormatException();
}
cnt++;
count+=d;
}catch (NumberFormatException e){
System.out.println("ERROR: "+s+" is not a legal number");
}
}
sc.close();
if(cnt==0) System.out.println("The average of 0 numbers is Undefined");
else if(cnt==1) System.out.printf("The average of 1 number is %.2f",count);
else System.out.printf("The average of %d numbers is %.2f",cnt,count/cnt);
}
}