Problem Description
The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.
For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.
简单的说就是电梯从0层开始,上升一层6秒下降一层是4秒,在每一层都需要等5秒
Input
There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.
Output
Print the total time on a single line for each test case.
Sample Input
1 2
3 2 3 1
0
Sample Output
17
41
Solution
import java.util.Scanner;
public class Solution1008 {
public static void main(String[] args) {
Scanner sc = new Scanner(System.in);
while (sc.hasNext()) {
int n = sc.nextInt();
if (n == 0) {
break;
}
int arr[] = new int[n];
for (int i = 0; i < n; i++) {
arr[i] = sc.nextInt();
}
int total = 0;
for(int i=0;i<arr.length;i++){
if(i == 0){
total += arr[i]*6;
}else{
if(arr[i]>arr[i-1]){
total += 6*(arr[i]-arr[i-1]);
}else{
total += 4*(arr[i-1]-arr[i]);
}
}
}
total += arr.length*5;
System.out.println(total);
}
}
}