1086 Tree Traversals Again (25 分)
An inorder binary tree traversal can be implemented in a non-recursive way with a stack. For example, suppose that when a 6-node binary tree (with the keys numbered from 1 to 6) is traversed, the stack operations are: push(1); push(2); push(3); pop(); pop(); push(4); pop(); pop(); push(5); push(6); pop(); pop(). Then a unique binary tree (shown in Figure 1) can be generated from this sequence of operations. Your task is to give the postorder traversal sequence of this tree.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤30) which is the total number of nodes in a tree (and hence the nodes are numbered from 1 to N). Then 2N lines follow, each describes a stack operation in the format: "Push X" where X is the index of the node being pushed onto the stack; or "Pop" meaning to pop one node from the stack.
Output Specification:
For each test case, print the postorder traversal sequence of the corresponding tree in one line. A solution is guaranteed to exist. All the numbers must be separated by exactly one space, and there must be no extra space at the end of the line.
Sample Input:
6
Push 1
Push 2
Push 3
Pop
Pop
Push 4
Pop
Pop
Push 5
Push 6
Pop
Pop
Sample Output:
3 4 2 6 5 1
题目大意
树的递归遍历可以借助堆栈变成非递归遍历,本题提供非递归过程中堆栈操作顺序,以此构建二叉树,并求出这个二叉树的后序。
分析
本题「新瓶装旧酒」,本质依然是考察已知树的两种遍历序列求其他遍历序列,这个问题我已经在一篇博客专门详尽阐述了「知两序求两序」这类问题的解法[1],此题只需将问题转化为「知两序求两序」即可解出,观察可知,push的数为前序序列,pop的数为中序序列。
#include <iostream>
#include <vector>
#include <stack>
using namespace std;
vector<int> pre,in,post;
stack<int> st;
void post_travel(int root,int start,int end){
if(start>end) return;
int i=start;
while(i<=end && pre[root]!=in[i]) i++;
post_travel(root+1,start,i-1);
post_travel(root+1+i-start,i+1,end);
post.push_back(pre[root]);
}
int main(){
int n;
cin>>n;
for(int i=0;i<n*2;i++){
string s;
int val;
cin>>s;
if(s=="Push"){
cin>>val;
pre.push_back(val);
st.push(val);
}else if(!st.empty()){
in.push_back(st.top());
st.pop();
}
}
post_travel(0,0,n-1);
for(int i=0;i<n;i++){
if(i==0) cout<<post[i];
else cout<<" "<<post[i];
}
return 0;
}