题目内容:
你的程序要读入一行文本,其中以空格分隔为若干个单词,以‘.’结束。你要输出这行文本中每个单词的长度。这里的单词与语言无关,可以包括各种符号,比如“it's”算一个单词,长度为4。注意,行中可能出现连续的空格。
输入格式:
输入在一行中给出一行文本,以‘.’结束,结尾的句号不能计算在最后一个单词>的长度内。
输出格式:
在一行中输出这行文本对应的单词的长度,每个长度之间以空格隔开,行末>没有最后的空格。
输入样例:
It's great to see you here.
输出样例:
4 5 2 3 3 4
思路:使用String的split方法分割字符串放入数组,遍历数组元素,使用string的length方法得出长度
package www.sise.zhejiang.test06;
import java.util.Scanner;
/**
* @创建人 Zeng
* @创建时间 2019/10/21
* @描述
*/
public class Main {
public static void countWords()
{
Scanner sc = new Scanner(System.in);
String st = sc.nextLine();
// \s表示匹配任何空白字符,+表示匹配一次或多次
String[] words = st.split("\\s+");
int max = words.length - 1;
for (String word : words)
{
if (!word.equals(words[max]))
{
System.out.print(word.length() + " ");
}
else if (word.equals(words[max]) && word.length()!=1)
{
System.out.print(word.length()-1);
}
}
}
public static void main(String[] args) {
countWords();
}
}