题目描述
从键盘输入任意20个整型数,统计其中的负数个数并求所有正数的平均值。
保留两位小数
输入
无
输出
无
样例输入
1 2 3 4 5 6 7 8 9 10
-1 -2 -3 -4 -5 -6 -7 -8 -9 -10
样例输出
10
5.50
参考代码
#include <bits/stdc++.h>
using namespace std;
double f = 0,tot = 0,ans,z = 0;
int a[25];
int main() {
for (int i=1;i<=20;i++) {
cin>>a[i];
if (a[i] > 0) {
tot += a[i];
z++;
}
if (a[i] < 0) f++;
}
cout<<f<<endl;
cout<<fixed<<setprecision(2)<<tot/z;
return 0;
}
运行结果
- 若有问题,请评论出来!