Juniper vMX 实现EVPN

实验topo


EVPN-TOPO.png

说明:

版本:
juniper@vMX-1# run show version 
Hostname: vMX-1
Model: vmx
Junos: 14.1R1.10
......

vMX网卡对应关系
网卡1     RE
网卡2     RE
网卡3     ge-0/0/0
网卡4     ge-0/0/1
.
.
.
网卡10    ge-0/0/7

logical-system不支持EVPN(也就是只能在全局路由器下的routing-instance 才能用EVPN),所以这里跑了两台vMX,两台的ge-0/0/3桥接在一起(也就是两台vmx的第6块网卡桥接到一个VMnet上)。分别把两台的ge-0/0/1.100放入evpn instance 里面(全局路由器ge-0/0/1使用vlan-tagging),在这之前需要把各自vMX的ge-0/0/1和ge-0/0/2桥接在一起(把vMX1的ge-0/0/1和ge-0/0/2桥接在VMnetA,vMX2的ge-0/0/1和ge-0/0/2桥接在VMnetB)。两台vMX分别分出一个logical-system,放入接口ge-0/0/1.100来模拟用户。

vMX1的配置

logical-systems {
    r1 {
        interfaces {
            ge-0/0/2 {
                unit 100 {
                    vlan-id 100;
                    family inet {
                        address 192.168.14.1/24;
                    }
                }
            }
        }
  }
interfaces {
    ge-0/0/1 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        unit 100 {
            encapsulation vlan-bridge;
            vlan-id 100;
        }
    }
    ge-0/0/2 {
        vlan-tagging;
    }
    ge-0/0/3 {
        unit 0 {
            family inet {
                address 192.168.23.2/24;
            }
            family mpls;
        }
    }
    ge-0/0/7 {
        unit 0 {
            family inet {
                address 172.16.33.100/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 2.2.2.2/32;
            }
        }
    }
}
routing-options {
    autonomous-system 65000;
}
protocols {
    mpls {
        interface ge-0/0/3.0;
    }
    bgp {
        group internal {
            type internal;
            local-address 2.2.2.2;
            family inet-vpn {
                unicast;
            }
            family evpn {
                signaling;
            }
            neighbor 3.3.3.3;
        }
    }
    ospf {
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ge-0/0/3.0;
        }
    }
    ldp {
        interface ge-0/0/3.0;
    }
}
routing-instances {
    EVPN100 {
        instance-type evpn;
        vlan-id 100;
        interface ge-0/0/1.100;
        route-distinguisher 2.2.2.2:1;
        vrf-target target:1:1;
        protocols {
            evpn;
        }
    }
}

vMX2的配置

logical-systems {
    r4 {
        interfaces {
            ge-0/0/2 {
                unit 100 {
                    vlan-id 100;
                    family inet {
                        address 192.168.14.4/24;
                    }
                }
            }
        }
    }
interfaces {
    ge-0/0/1 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        unit 100 {
            encapsulation vlan-bridge;
            vlan-id 100;
        }
    }
    ge-0/0/2 {
        vlan-tagging;
    }
    ge-0/0/3 {
        unit 0 {
            family inet {
                address 192.168.23.3/24;
            }
            family mpls;
        }
    }
    ge-0/0/7 {
        unit 0 {
            family inet {
                address 172.16.33.200/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 3.3.3.3/32;
            }
        }
    }
}
routing-options {
    autonomous-system 65000;
}
protocols {
    mpls {
        interface ge-0/0/3.0;
    }
    bgp {
        group internal {
            type internal;
            local-address 3.3.3.3;
            family inet-vpn {
                unicast;
            }
            family evpn {
                signaling;
            }
            neighbor 2.2.2.2;
        }
    }
    ospf {
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ge-0/0/3.0;
        }
    }
    ldp {
        interface ge-0/0/3.0;
    }
}
routing-instances {
    EVPN100 {
        instance-type evpn;
        vlan-id 100;
        interface ge-0/0/1.100;
        route-distinguisher 2.2.2.2:1;
        vrf-target target:1:1;
        protocols {
            evpn;
        }
    }
}

查看路由表vMX1

juniper@vMX-1> show route table EVPN100.evpn.0 

EVPN100.evpn.0: 4 destinations, 4 routes (4 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2:2.2.2.2:1::100::00:05:86:71:05:02/304               
                   *[EVPN/170] 00:06:45
                      Indirect
2:2.2.2.2:1::100::00:05:86:71:b2:02/304               
                   *[BGP/170] 00:05:27, localpref 100, from 3.3.3.3
                      AS path: I, validation-state: unverified
                    > to 192.168.23.3 via ge-0/0/3.0
3:2.2.2.2:1::100::2.2.2.2/304               
                   *[EVPN/170] 00:06:53
                      Indirect
3:2.2.2.2:1::100::3.3.3.3/304               
                   *[BGP/170] 00:05:27, localpref 100, from 3.3.3.3
                      AS path: I, validation-state: unverified
                    > to 192.168.23.3 via ge-0/0/3.0
##########
juniper@vMX-1> show route table bgp.evpn.0 

bgp.evpn.0: 2 destinations, 2 routes (2 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2:2.2.2.2:1::100::00:05:86:71:b2:02/304               
                   *[BGP/170] 00:06:59, localpref 100, from 3.3.3.3
                      AS path: I, validation-state: unverified
                    > to 192.168.23.3 via ge-0/0/3.0
3:2.2.2.2:1::100::3.3.3.3/304               
                   *[BGP/170] 00:06:59, localpref 100, from 3.3.3.3
                      AS path: I, validation-state: unverified
                    > to 192.168.23.3 via ge-0/0/3.0

在vrf EVPN100中junos会默认导入两条策略

juniper@vMX-1> show route instance EVPN100 extensive 
EVPN100:
  Router ID: 0.0.0.0
                          State: Active        
  Interfaces:
    ge-0/0/1.100
  Route-distinguisher: 2.2.2.2:1
  Vrf-import: [ __vrf-import-EVPN100-internal__ ]
  Vrf-export: [ __vrf-export-EVPN100-internal__ ]
  Vrf-import-target: [ target:1:1 ]
  Vrf-export-target: [ target:1:1 ]
  Fast-reroute-priority: low
  Tables:
    EVPN100.evpn.0         : 0 routes (0 active, 0 holddown, 0 hidden)
    EVPN100.evpn.0         : 4 routes (4 active, 0 holddown, 0 hidden)
###########
juniper@vMX-1> show policy ?           
Possible completions:
  <[Enter]>            Execute this command
  <policy>             Name of policy
  __vrf-export-EVPN100-internal__  
  __vrf-import-EVPN100-internal__  
  conditions           Show conditions used by policy
  damping              Show state of route flap damping
  fabric               Internal fabric state
  logical-system       Name of logical system, or 'all'
  |                    Pipe through a command

############
juniper@vMX-1> show policy __vrf-export-EVPN100-internal__ 
Policy __vrf-export-EVPN100-internal__:
    Term unnamed:
        then community + __vrf-community-EVPN100-common-internal__ [target:1:1 ] accept

############
juniper@vMX-1> show policy __vrf-import-EVPN100-internal__ 
Policy __vrf-import-EVPN100-internal__:
    Term unnamed:
        from community __vrf-community-EVPN100-common-internal__ [target:1:1 ]
        then accept
    Term unnamed:
        then reject

连通性测试

juniper@vMX-1# run ping 192.168.14.4 logical-system r1 source 192.168.14.1 rapid 
PING 192.168.14.4 (192.168.14.4): 56 data bytes
!!!!!
--- 192.168.14.4 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max/stddev = 3.391/5.797/8.227/1.836 ms

###########
juniper@vMX-1# run show arp logical-system r1 no-resolve 
MAC Address       Address         Interface     Flags
00:05:86:71:b2:02 192.168.14.4    ge-0/0/2.100         none

###########
juniper@vMX-1# run show evpn instance EVPN100 extensive 
Instance: EVPN100
  Route Distinguisher: 2.2.2.2:1
  VLAN ID: 100
  Per-instance MAC route label: 299776
  Per-instance multicast route label: 299792
  MAC database status                Local  Remote
    Total MAC addresses:                 1       1
    Default gateway MAC addresses:       0       0
  Number of local interfaces: 1 (1 up)
    Interface name  ESI                            Mode             SH label
    ge-0/0/1.100    00:00:00:00:00:00:00:00:00:00  single-homed   
  Number of IRB interfaces: 0 (0 up)
  Number of neighbors: 1
    3.3.3.3
      Received routes
        MAC address advertisement:              1
        MAC+IP address advertisement:           0
        Inclusive multicast:                    1
        Ethernet auto-discovery:                0
  Number of ethernet segments: 0

vMX1的ge-0/0/3.0 接口抓包
Fution和VMware workstations上对应的VMnet接口其实就是一个HUB,想要对ge-0/0/3.0接口的包,只需要抓ge-0/0/3桥接的虚拟接口。
抓包截图如下:


EVPN-pac.png

vMX 各接口MAC地址:

juniper@vMX-1# run show interfaces ge-0/0/1 | match "Current address" 
  Current address: 00:05:86:71:05:01, Hardware address: 00:05:86:71:05:01

[edit]
juniper@vMX-1# run show interfaces ge-0/0/2 | match "Current address"    
  Current address: 00:05:86:71:05:02, Hardware address: 00:05:86:71:05:02

[edit]
juniper@vMX-1# run show interfaces ge-0/0/3 | match "Current address"    
  Current address: 00:05:86:71:05:03, Hardware address: 00:05:86:71:05:03

[edit]

vMX2各接口MAC地址:
juniper@vMX-2# run show interfaces ge-0/0/1 | match "Current address" 
  Current address: 00:05:86:71:b2:01, Hardware address: 00:05:86:71:b2:01

[edit]
juniper@vMX-2# run show interfaces ge-0/0/2 | match "Current address"    
  Current address: 00:05:86:71:b2:02, Hardware address: 00:05:86:71:b2:02

[edit]
juniper@vMX-2# run show interfaces ge-0/0/3 | match "Current address"    
  Current address: 00:05:86:71:b2:03, Hardware address: 00:05:86:71:b2:03

[edit]
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 204,590评论 6 478
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 86,808评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 151,151评论 0 337
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,779评论 1 277
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,773评论 5 367
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,656评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,022评论 3 398
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,678评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 41,038评论 1 299
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,659评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,756评论 1 330
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,411评论 4 321
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,005评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,973评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,203评论 1 260
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,053评论 2 350
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,495评论 2 343

推荐阅读更多精彩内容