A - 3:
Problem:
乘积尾零
如下的10行数据,每行有10个整数,请你求出它们的乘积的末尾有多少个零?
5650 4542 3554 473 946 4114 3871 9073 90 4329
2758 7949 6113 5659 5245 7432 3051 4434 6704 3594
9937 1173 6866 3397 4759 7557 3070 2287 1453 9899
1486 5722 3135 1170 4014 5510 5120 729 2880 9019
2049 698 4582 4346 4427 646 9742 7340 1230 7683
5693 7015 6887 7381 4172 4341 2909 2027 7355 5649
6701 6645 1671 5978 2704 9926 295 3125 3878 6785
2066 4247 4800 1578 6652 4616 1113 6205 3264 2915
3966 5291 2904 1285 2193 1428 2265 8730 9436 7074
689 5510 8243 6114 337 4096 8199 7313 3685 211
注意:需要提交的是一个整数,表示末尾零的个数。不要填写任何多余内容。
Solution:
任何一个数都可以分解为若干个素数的乘积
每个数分别对2, 5取余,并计算全部数可被2和5取余的次数 即可算出0的个数
Code:
#include<iostream>
#include<cmath>
#include<algorithm>
using namespace std;
int countTwo = 0;
int countFive = 0;
void check(int num);
int main(void) {
int data;
int temp = 1;
for (int i = 0; i < 100; i++) {
cin >> data;
check(data);
}
cout << min(countFive, countTwo);
return 0;
}
void check(int num) {
for (int i = 2; i <= 5; i++) {
for (; num % i == 0;) {
if (i == 2)
countTwo++;
else if (i == 5)
countFive++;
num /= i;
}
}
}
Ans
31
A - 4
Problem:
第几个幸运数
到x星球旅行的游客都被发给一个整数,作为游客编号。
x星的国王有个怪癖,他只喜欢数字3,5和7。
国王规定,游客的编号如果只含有因子:3,5,7,就可以获得一份奖品。
我们来看前10个幸运数字是:
3 5 7 9 15 21 25 27 35 45
因而第11个幸运数字是:49
小明领到了一个幸运数字 59084709587505,他去领奖的时候,人家要求他准确地说出这是第几个幸运数字,否则领不到奖品。
请你帮小明计算一下,59084709587505是第几个幸运数字。
需要提交的是一个整数,请不要填写任何多余内容。
Solution:
用筛法的思想
数组预置数字 1
对数组所有的数 不断 * 3 把<=MAX 的数纳入数组arr
对数组所有的数 不断 * 5 把<=MAX 的数纳入数组arr
对数组所有的数 不断 * 7 把<=MAX 的数纳入数组arr
ans = arr.size() - 1
Code:
long long MAXN = 59084709587505;
int main(void) {
vector<long long> arr(1,1);
int size;
bool flag = false;
int num[3] = { 3,5,7 };
int step = 0;
long long temp;
for (int i = 0; i < 3; i++) {
size = arr.size();
for (int j = 0; j < size; j++) {
for ( temp = arr[j] * num[i];temp<=MAXN;) {
arr.push_back(temp);
temp *= num[i];
}
}
}
cout << arr.size() - 1;
return 0;
}
Ans
1905
A - 5
Problem:
打印图形
如下的程序会在控制台绘制分形图(就是整体与局部自相似的图形)。
当n=1,2,3的时候,输出如下:
请仔细分析程序,并填写划线部分缺少的代码。
n=1时:
o
ooo
o
n=2时:
o
ooo
o
o o o
ooooooooo
o o o
o
ooo
o
n=3时:
o
ooo
o
o o o
ooooooooo
o o o
o
ooo
o
o o o
ooo ooo ooo
o o o
o o o o o o o o o
ooooooooooooooooooooooooooo
o o o o o o o o o
o o o
ooo ooo ooo
o o o
o
ooo
o
o o o
ooooooooo
o o o
o
ooo
o
源程序:
#include <stdio.h>
#include <stdlib.h>
void show(char* buf, int w){
int i,j;
for(i=0; i<w; i++){
for(j=0; j<w; j++){
printf("%c", buf[i*w+j]==0? ' ' : 'o');
}
printf("\n");
}
}
void draw(char* buf, int w, int x, int y, int size){
if(size==1){
buf[y*w+x] = 1;
return;
}
int n = _________________________ ; //填空
draw(buf, w, x, y, n);
draw(buf, w, x-n, y ,n);
draw(buf, w, x+n, y ,n);
draw(buf, w, x, y-n ,n);
draw(buf, w, x, y+n ,n);
}
int main()
{
int N = 3;
int t = 1;
int i;
for(i=0; i<N; i++) t *= 3;
char* buf = (char*)malloc(t*t);
for(i=0; i<t*t; i++) buf[i] = 0;
draw(buf, t, t/2, t/2, t);
show(buf, t);
free(buf);
return 0;
}
注意:只提交划线部分缺少的代码,不要抄写任何已经存在的代码或符号。
Sulotion:
size = 为整个图形的高
由题分析可知 N++
则size*=3
Ans:
int n = size / 3;
A - 8
Problem:
你有一张某海域NxN像素的照片,"."表示海洋、"#"表示陆地,如下所示:
.......
.##....
.##....
....##.
..####.
...###.
.......
其中"上下左右"四个方向上连在一起的一片陆地组成一座岛屿。例如上图就有2座岛屿。
由于全球变暖导致了海面上升,科学家预测未来几十年,岛屿边缘一个像素的范围会被海水淹没。具体来说如果一块陆地像素与海洋相邻(上下左右四个相邻像素中有海洋),它就会被淹没。
例如上图中的海域未来会变成如下样子:
.......
.......
.......
.......
....#..
.......
.......
请你计算:依照科学家的预测,照片中有多少岛屿会被完全淹没。
输入
第一行包含一个整数N。 (1 <= N <= 1000)
以下N行N列代表一张海域照片。
照片保证第1行、第1列、第N行、第N列的像素都是海洋。
输出
一个整数表示答案。
样例输入
7
.......
.##....
.##....
....##.
..####.
...###.
.......
样例输出
1
Solution:
DFS 数连通块个数 并对可能会成为海洋的陆地进行标记并计数 再对原有陆地进行计数 如果原有陆地个数和可能变成海洋的陆地个数相等 则该岛屿为沉没岛屿
注意 有可能有些岛屿会因为变暖变成两块岛屿 所以通过变化前岛屿个数和变化后岛屿个数之差是不可行的
如果
Code:
#include<iostream>
#include<cmath>
#include<algorithm>
#include<vector>
#include<string>
using namespace std;
int N;
int count1 = 0;
int count2 = 0;
int dirX[4] = { -1, 0, 1, 0 };
int dirY[4] = { 0, -1, 0, 1 };
void dfs(vector<string > & MAP, vector<vector<bool> > &from, int x, int y);
int main(void) {
int count = 0;
cin >> N;
string s;
vector<bool> arr(N, 0);
vector<vector<bool> > from(N, arr);
vector<string > MAP;
for (int i = 0; i < N; i++) {
cin >> s;
MAP.push_back(s);
}
for (int i = 1; i < N; i++) {
for (int j = 1; j < N; j++) {
if (MAP[i][j] == '#'&&from[i][j] == 0) {
count1 = 0;
count2 = 0;
dfs(MAP, from, i, j);
if (count1 == count2)
count++;
}
}
}
/*cout << endl;
for (int i = 0; i < N; i++) {
for (int j = 0; j < N; j++) {
cout << MAP[i][j];
}
cout << endl;
}
for (int i = 1; i < N; i++) {
for (int j = 1; j < N; j++) {
if (MAP[i][j] == '#'&&to[i][j] == 0) {
dfs(MAP, to, i, j);
count2++;
}
}
}*/
cout << count;
return 0;
}
void dfs(vector<string > & MAP, vector<vector<bool> > &from, int x, int y) {
from[x][y] = 1;
count1++;
int tempX;
int tempY;
for (int i = 0; i < 4; i++) {
tempX = x + dirX[i];
tempY = y + dirY[i];
if(MAP[tempX][tempY]=='#' && from[tempX][tempY] == 0)
dfs(MAP, from, tempX, tempY);
if (MAP[tempX][tempY] == '.') {
if (MAP[x][y] != '/')
count2++;
MAP[x][y] = '/';
}
}
}