poj1679 The Unique MST

题目:

Description
Given a connected undirected graph, tell if its minimum spanning tree is unique. Definition 1 (Spanning Tree): Consider a connected, undirected graph G = (V, E). A spanning tree of G is a subgraph of G, say T = (V', E'), with the following properties: 1. V' = V. 2. T is connected and acyclic. Definition 2 (Minimum Spanning Tree): Consider an edge-weighted, connected, undirected graph G = (V, E). The minimum spanning tree T = (V, E') of G is the spanning tree that has the smallest total cost. The total cost of T means the sum of the weights on all the edges in E'.
Input
The first line contains a single integer t (1 <= t <= 20), the number of test cases. Each case represents a graph. It begins with a line containing two integers n and m (1 <= n <= 100), the number of nodes and edges. Each of the following m lines contains a triple (xi, yi, wi), indicating that xi and yi are connected by an edge with weight = wi. For any two nodes, there is at most one edge connecting them.
Output
For each input, if the MST is unique, print the total cost of it, or otherwise print the string 'Not Unique!'.
Sample Input
2
3 3
1 2 1
2 3 2
3 1 3
4 4
1 2 2
2 3 2
3 4 2
4 1 2
Sample Output
3
Not Unique!

这道题目是让给你一个无向图,让你判断它的最小生成树是否具有唯一性,如果是就输出最小生成树的权值,否则输出"Not Unique!"。
以下是我写的代码和我的个人理解,仅供参考。

参考代码:

#include <iostream>//使用Kruskal算法;
#include <algorithm>
#include <cstring>
using namespace std;
const int N = 10000+5;
const int M = 100+5;

int n, m;
int par[M];//保存每个点的根值;//并查集;
int vis[N];//保存访问过的边;
int visnum;//已经访问过多少条边;

struct node {
    int st, ed, cost;
} Points[N];

void init() {
    memset(Points, 0, sizeof(Points));
    for (int i = 1;i < M;++i) {//并查集初始化;
        par[i] = i;
    }
    memset(vis, -1, sizeof(vis));
    visnum = 0;
}

void input() {
    int a, b, c;
    for (int i = 0;i < m;++i) {
        cin >> a >> b >> c;
        Points[i].st = a;
        Points[i].ed = b;
        Points[i].cost = c;
    }
}

bool cmp(const node &a, const node &b) {//按边的权值排序;
    return a.cost < b.cost;
}

int find(int x) {//查询树的根;
    if (par[x] == x) return x;
    else return find(par[x]);
}

void unite(int a, int b) {//合并a和b所属的集合;
    a = find(a);
    b = find(b);
    if (a != b)
        par[a] = b;
}

int mintree() {//求最小生成树;//考虑不连通的情况;
    int res = 0;
    int cnt = 0;
    for (int i = 0;i < m;++i) {
        node e = Points[i];
        int a = find(e.st), b = find(e.ed);//并查集;
        if (a != b) {//a和b不属于同一个集合, 表明该条边没有与其他边构成环;
            unite(e.st, e.ed);
            vis[visnum++] = i;//表明该条边已经被用过;
            res += e.cost;
            ++cnt;
        }
    }
    if (cnt < n - 1) return -1;//根据树的性质;//树的边数=结点数-1;
    return res;
}

int sectree() {//求次小生成树;
    int res = 0;
    int i;
    int minnum = 999999;//寻找次小生成树;
    for (int k = 0;k < visnum;++k) {//保证至少有一条边不是最小生成树的边;
        int cnt = 0;
        res = 0;
        for (int j = 1;j < M;++j) {//初始化并查集;
            par[j] = j;
        }
        for (i = 0;i < m;++i) {
            if (vis[k] != i) {
                node e = Points[i];
                int a = find(e.st), b = find(e.ed);//并查集;
                if (a != b) {
                    unite(e.st, e.ed);
                    res += e.cost;
                    ++cnt;
                }
                //cout << "xyz" << endl;
            }
        }
        if (cnt < n - 1) continue;
        if (vis[k] != i && minnum > res) {//寻找除最小生成树以外的权值最小的树;
            minnum = res;
        }
    }
    return minnum;
}

int main() {
    ios::sync_with_stdio(false);
    cin.tie(NULL);
    int t;
    cin >> t;
    while (t--) {
        cin >> n >> m;
        if (n == 1) {//特殊情况: 只有1个点;
            cout << 0 << endl;
            continue;
        }
        if (m == 0) {//特殊情况: 没有边;
            cout << "Not Unique!" << endl;
            continue;
        }
        init();
        input();
        sort(Points, Points + m, cmp);//按权值大小排序;
        int ans1 = mintree();
        int ans2 = sectree();
        if (ans1 == ans2 || ans1 == -1) {//若次小生成树的大小不等于最小生成树的大小, 则表明最小生成树是唯一的;
            cout << "Not Unique!" << endl;
        } 
        else cout << ans1 << endl;
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 202,980评论 5 476
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 85,178评论 2 380
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 149,868评论 0 336
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,498评论 1 273
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,492评论 5 364
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,521评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,910评论 3 395
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,569评论 0 256
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,793评论 1 296
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,559评论 2 319
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,639评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,342评论 4 318
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,931评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,904评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,144评论 1 259
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,833评论 2 349
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,350评论 2 342

推荐阅读更多精彩内容