1025 PAT Ranking (25 分)

Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (≤100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (≤300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

分析

  • 结构体储存id,成绩,local rank和final rank,考场号
  • sort一遍后从第一个开始计算排名
for(int k=1;k<v.size();k++){
   v[k].loc_rank = (v[k].score==v[k-1].score) ? (v[k-1].loc_rank) : (k+1);
   fin.push_back(v[k]);
}
  • local rank 在每次读入一个考场数据的时候就可以计算,并push到全部学生成绩的fin向量中
  • 最后sort向量fin,再计算排名
  • 注意idprintf("%013lld",fin[i].id)
#include <iostream>
#include <algorithm>
#include <vector>

using namespace std;

struct node{
    long long id;
    int score,loc_rank,fin_rank,loc_id;
};

bool cmp(node a,node b){
    return a.score==b.score ? a.id<b.id : a.score>b.score;
}

int main()
{
    int n,m;
    vector<node> fin;
    scanf("%d",&n);
    for(int i=1;i<=n;i++){
        scanf("%d",&m);
        vector<node> v(m);
        for(int j=0;j<m;j++){
            scanf("%lld%d",&v[j].id,&v[j].score);
            v[j].loc_id = i;
        }
        sort(v.begin(),v.end(),cmp);
        v[0].loc_rank = 1;
        fin.push_back(v[0]);
        for(int k=1;k<v.size();k++){
            v[k].loc_rank = (v[k].score==v[k-1].score) ? (v[k-1].loc_rank) : (k+1);
            fin.push_back(v[k]);
        }
    }
    sort(fin.begin(),fin.end(),cmp);
    fin[0].fin_rank = 1;
    for(int i=1;i<fin.size();i++){
        fin[i].fin_rank = (fin[i].score==fin[i-1].score) ? (fin[i-1].fin_rank) : (i+1);
    }
    printf("%d\n",fin.size());
    for(int i=0;i<fin.size();i++){
        printf("%013lld %d %d %d\n",fin[i].id,fin[i].fin_rank,fin[i].loc_id,fin[i].loc_rank);
    }
}

参考

©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 196,200评论 5 462
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 82,526评论 2 373
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 143,321评论 0 325
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,601评论 1 267
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 61,446评论 5 358
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,345评论 1 273
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,753评论 3 387
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,405评论 0 255
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,712评论 1 294
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,743评论 2 314
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,529评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,369评论 3 315
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,770评论 3 300
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,026评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,301评论 1 251
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,732评论 2 342
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,927评论 2 336

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,260评论 0 10
  • 走着走着就不年轻了。 以前可以走大半个城市,等到天微微亮的时候,怀抱相拥抵御寒气。 以前可以彻夜无眠,为等一个回复...
    柳水阅读 140评论 0 0
  • 人们常常说自己的脾气不好老是回家就发火,自己控制不住,发了火后自己也很后悔,为什么要对自己家人发火呢,难道家人就是...
    想写出好文笔的孩子阅读 1,050评论 0 0
  • ℡ 大学,就应该是早起吃点早餐,跑跑步; 专业课认真听,公共课看看自己喜欢的杂志; 中午小睡一会,下午...
    XINGTINGPU阅读 434评论 0 1
  • 01 四川九寨沟地震事发后,不少演艺明星通过壹基金捐款,这本是件振奋人心的好事情,可是却有所谓道德人士偏偏在捐款金...
    装睡猫阅读 390评论 0 6