This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
#include <iostream>
#include<map>
#include<iomanip>
#include<stdio.h>
using namespace std;
int main()
{
map<int,double> polynomial;
int n,input1;
double input2;
scanf("%d",&n);
for (int i=0;i<n ;i++ ){
cin>>input1>>input2;
polynomial[input1]=input2;
}
scanf("%d",&n);
for (int i=0;i<n ;i++ ){
cin>>input1>>input2;
if(polynomial.find(input1)==polynomial.end()){
polynomial[input1]=input2;
}
else{
polynomial[input1]=polynomial[input1]+input2;
}
if(polynomial[input1]==0)
polynomial.erase(input1);
}
map<int,double>::reverse_iterator i;
cout<<polynomial.size();
for (i=polynomial.rbegin();i!=polynomial.rend();i++){
cout<<" "<<i->first<<" "<<fixed<<setprecision(1)<<i->second; ////fixed表示小数点右边有多少位数字
}
return 0;
}
纠结错误
1.当多项式系数相加为零时要把map中的项删除
2.map默认从小到大,可以用逆向迭代器逆序输出
3.不会用map可以用数组代替