1025. PAT Ranking


Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:

registration_number final_rank location_number local_rank

The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.

Sample Input:

2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85

Sample Output:

9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4

题目大意

有n个考场,每个考场有一定数量的考生,按照排名、准考证号升序排列,输出准考证号、分数、考场号、考场内排名。

思路

主要利用sort函数完成排序操作,步骤如下:

  • 先读入每个考场的信息,并进行排序;
  • 所有考场汇总后再进行排序。

代码实现

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

struct Student
{
    char id[15];
    int score;
    int trank;      // 总排名
    int lo;         // 考场编号
    int lrank;      // 地区排名
} stu[30010];

bool cmp(Student a, Student b)
{
    if (a.score != b.score)
        return a.score > b.score;       // 分数不同,按排名升序排列
    else
        return strcmp(a.id, b.id) < 0;      // 分数相同,按准考证号升序排列
}

int main(void)
{
    int n;              // 考场数量
    scanf("%d", &n);
    int num;            // 当前考场考生数
    int order = 1;      // 记录当前考生序号
    int total = 0;      // 统计总考生数
    
    for (int i = 1; i <= n; i++)
    {
        scanf("%d", &num);
        for (order; order <= num + total; order++)
        {
            scanf("%s %d", stu[order].id, &stu[order].score);
            stu[order].lo = i;
        }
        sort(stu+total+1, stu+order, cmp);
        stu[total+1].lrank = 1;
        for (int j = total+2; j < order; j++)
            if (stu[j].score == stu[j-1].score)
                stu[j].lrank = stu[j-1].lrank;
            else
                stu[j].lrank = j - total;
        total += num;
    }
    sort(stu+1, stu+order, cmp);
    stu[1].trank = 1;
    for (int i = 2; i <= total; i++)
        if (stu[i].score == stu[i-1].score)
            stu[i].trank = stu[i-1].trank;
        else
            stu[i].trank = i;
    printf("%d\n", total);
    for (int i = 1; i <=total; i++)
        printf("%s %d %d %d\n", stu[i].id, stu[i].trank, stu[i].lo, stu[i].lrank);
} 
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 202,905评论 5 476
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 85,140评论 2 379
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 149,791评论 0 335
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,483评论 1 273
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,476评论 5 364
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,516评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,905评论 3 395
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,560评论 0 256
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,778评论 1 296
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,557评论 2 319
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,635评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,338评论 4 318
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,925评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,898评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,142评论 1 259
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 42,818评论 2 349
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,347评论 2 342

推荐阅读更多精彩内容

  • TCP/IP协议三次握手与四次握手流程解析 HTTP协议—— 简单认识TCP/IP协议 TCP/IP协议入门(一)...
    xiari1991阅读 414评论 0 0
  • 真想好好醉一场 独饮难得真豪放 一两好友把酒劝 吆五喝六慢疯狂 开怀畅饮为哪般 忘却情肠笑玉皇 且歌且舞且洋相 不...
    武兵阅读 183评论 0 0
  • 把一个自己喜欢的网站做出来。包含数据库,php,后台搭建。 到网上去搜索素材,到网上查询信息,不懂得自己解决,一个...
    高飞Y阅读 319评论 0 1
  • 你是不是觉得生活无趣却又不知道如何有趣?你是不是对千篇一律的生活感到痛苦却又无法自拔?那么来看看这本书吧。最近键人...
    伟大的平凡人阅读 574评论 2 1