Programming Ability Test (PAT) is organized by the College of Computer Science and Technology of Zhejiang University. Each test is supposed to run simultaneously in several places, and the ranklists will be merged immediately after the test. Now it is your job to write a program to correctly merge all the ranklists and generate the final rank.
Input Specification:
Each input file contains one test case. For each case, the first line contains a positive number N (<=100), the number of test locations. Then N ranklists follow, each starts with a line containing a positive integer K (<=300), the number of testees, and then K lines containing the registration number (a 13-digit number) and the total score of each testee. All the numbers in a line are separated by a space.
Output Specification:
For each test case, first print in one line the total number of testees. Then print the final ranklist in the following format:
registration_number final_rank location_number local_rank
The locations are numbered from 1 to N. The output must be sorted in nondecreasing order of the final ranks. The testees with the same score must have the same rank, and the output must be sorted in nondecreasing order of their registration numbers.
Sample Input:
2
5
1234567890001 95
1234567890005 100
1234567890003 95
1234567890002 77
1234567890004 85
4
1234567890013 65
1234567890011 25
1234567890014 100
1234567890012 85
Sample Output:
9
1234567890005 1 1 1
1234567890014 1 2 1
1234567890001 3 1 2
1234567890003 3 1 2
1234567890004 5 1 4
1234567890012 5 2 2
1234567890002 7 1 5
1234567890013 8 2 3
1234567890011 9 2 4
题目大意
有n个考场,每个考场有一定数量的考生,按照排名、准考证号升序排列,输出准考证号、分数、考场号、考场内排名。
思路
主要利用sort函数完成排序操作,步骤如下:
- 先读入每个考场的信息,并进行排序;
- 所有考场汇总后再进行排序。
代码实现
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct Student
{
char id[15];
int score;
int trank; // 总排名
int lo; // 考场编号
int lrank; // 地区排名
} stu[30010];
bool cmp(Student a, Student b)
{
if (a.score != b.score)
return a.score > b.score; // 分数不同,按排名升序排列
else
return strcmp(a.id, b.id) < 0; // 分数相同,按准考证号升序排列
}
int main(void)
{
int n; // 考场数量
scanf("%d", &n);
int num; // 当前考场考生数
int order = 1; // 记录当前考生序号
int total = 0; // 统计总考生数
for (int i = 1; i <= n; i++)
{
scanf("%d", &num);
for (order; order <= num + total; order++)
{
scanf("%s %d", stu[order].id, &stu[order].score);
stu[order].lo = i;
}
sort(stu+total+1, stu+order, cmp);
stu[total+1].lrank = 1;
for (int j = total+2; j < order; j++)
if (stu[j].score == stu[j-1].score)
stu[j].lrank = stu[j-1].lrank;
else
stu[j].lrank = j - total;
total += num;
}
sort(stu+1, stu+order, cmp);
stu[1].trank = 1;
for (int i = 2; i <= total; i++)
if (stu[i].score == stu[i-1].score)
stu[i].trank = stu[i-1].trank;
else
stu[i].trank = i;
printf("%d\n", total);
for (int i = 1; i <=total; i++)
printf("%s %d %d %d\n", stu[i].id, stu[i].trank, stu[i].lo, stu[i].lrank);
}