传送门
https://pintia.cn/problem-sets/994805260223102976/problems/994805318855278592
题目
让我们用字母B来表示“百”、字母S表示“十”,用“12...n”来表示个位数字n(<10),换个格式来输出任一个不超过3位的正整数。例如234应该被输出为BBSSS1234,因为它有2个“百”、3个“十”、以及个位的4。
输入格式:每个测试输入包含1个测试用例,给出正整数n(<1000)。
输出格式:每个测试用例的输出占一行,用规定的格式输出n。
输入样例1:
234
输出样例1:
BBSSS1234
输入样例2:
23
输出样例2:
SS123
分析
C++实现方法是:
读入一个数,然后求出其个位十位百位的值,然后根据要求输出结果即可。
Java实现方法与C++类似,这里不再赘述。
源代码
//C/C++实现
#include <stdio.h>
#include <iostream>
#include <string.h>
#include <vector>
using namespace std;
int main(){
int n, count = 0, ge = 0, shi = 0, bai = 0;
scanf("%d", &n);
while(n != 0){
if(count == 0){
ge = n % 10;
n /= 10;
count ++;
}
else if(count == 1){
shi = n % 10;
n /= 10;
count ++;
}
else{
bai = n % 10;
n /= 10;
}
}
if(bai != 0){
for(int i=0;i<bai;i++){
printf("%c", 'B');
}
}
if(shi != 0){
for(int j=0;j<shi;j++){
printf("%c", 'S');
}
}
if(ge != 0){
for(int k=0;k<ge;k++){
printf("%d", k+1);
}
}
printf("%c", '\n');
return 0;
}
//Java实现
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner = new Scanner(System.in);
int num = scanner.nextInt();
int ge =0 , shi = 0 , bai = 0 , count = 0;
if(num > 0 && num < 1000){
while(num != 0){
if(count == 0) {
ge = num % 10;
num /= 10;
count++;
}
else if(count == 1){
shi = num % 10;
num /= 10;
count++;
}
else{
bai = num % 10;
num /= 10;
count++;
}
}
if(bai != 0){
for(int i=0;i<bai;i++){
System.out.print('B');
}
}
if(shi != 0){
for(int j=0;j<shi;j++){
System.out.print('S');
}
}
if(ge != 0){
for(int k=0;k<ge;k++){
System.out.print(k+1);
}
}
}
}
}