The K-P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K-P factorization of N for any positive integers N, K and P.
Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (<=400), K (<=N) and P (1<P<=7). The numbers in a line are separated by a space.
Output Specification:
For each case, if the solution exists, output in the format: N = n1^P + ... nK^P, where ni (i=1, ... K) is the i-th factor. All the factors must be printed in non-increasing order.
Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 122 + 42 + 22 + 22 + 12, or 112 + 62 + 22 + 22 + 22, or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen -- sequence { a1, a2, ... aK } is said to be larger than { b1, b2, ... bK } if there exists 1<=L<=K such that ai=bi for i<L and aL>bL
If there is no solution, simple output "Impossible".
Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible
思路:
dfs搜索
num:从p次根号n开始从大到小枚举
nowk:枚举的个数
nowsum:枚举数的和
noepowsum:当前结果
通过递归dfs,找到出口,找到递归的方式。
#include<bits/stdc++.h>
using namespace std;
int n,k,p;
int sum=0;
vector<int>result,temp;
void dfs(int num,int nowk,int nowsum,int nowpowsum)
{
if(nowk>k||nowpowsum>n) return;
if(nowk==k&&nowpowsum==n&&nowsum>sum)
{
result=temp;
sum=nowsum;
}
if(num>=1)
{
temp.push_back(num);
dfs(num,nowk+1,nowsum+num,nowpowsum+pow(num,p));
temp.pop_back();
dfs(num-1,nowk,nowsum,nowpowsum);
}
}
int main()
{
scanf("%d%d%d",&n,&k,&p);
dfs((int)pow(n,1.0/p)+1,0,0,0);
if(result.size()==k)
{
printf("%d = %d^%d",n,result[0],p);
for(int i=1; i<result.size(); i++)
{
printf(" + %d^%d",result[i],p);
}
}
else
{
printf("Impossible");
}
}