02-线性结构3 Reversing Linked List

传送门

02-线性结构3 Reversing Linked List(25 分)

题目

Given a constant K and a singly linked list L, you are supposed to reverse the links of every K elements on L. For example, given L being 1→2→3→4→5→6, if K=3, then you must output 3→2→1→6→5→4; if K=4, you must output 4→3→2→1→5→6.

Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, a positive N (≤10​^5​​ ) which is the total number of nodes, and a positive K (≤N) which is the length of the sublist to be reversed. The address of a node is a 5-digit nonnegative integer, and NULL is represented by -1.
Then N lines follow, each describes a node in the format:
Address Data Next
where Address is the position of the node, Data is an integer, and Next is the position of the next node.

Output Specification:

For each case, output the resulting ordered linked list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:

00100 6 4
00000 4 99999
00100 1 12309
68237 6 -1
33218 3 00000
99999 5 68237
12309 2 33218
Sample Output:

00000 4 33218
33218 3 12309
12309 2 00100
00100 1 99999
99999 5 68237
68237 6 -1

提交代码

#include <iostream>
#include <cstdlib>
#include <cstdio>
#define MAX 100000

using namespace std;

typedef struct _node {
    int num;
    int next;
} Node;

Node a[MAX];
Node* reverse(Node *p, int k);

int main(int argc, char const * argv[])
{
    int head, n, k;
    cin >> head >> n >> k;
    int add;
    for ( int i=0; i<n; i++ ) {
        cin >> add;
        cin >> a[add].num >> a[add].next;
    }
    Node nodep;
    nodep.next = head;
    head = reverse(&nodep,k)->next;
    int flag = 1;
    do {
        printf("%05d %d ", head, a[head].num);
        if ( a[head].next == -1 ) {
            printf("-1");
            flag = 0;
        }
        else printf("%05d\n", a[head].next);
        head = a[head].next;
    } while ( flag );
    return 0;
}

Node* reverse(Node *p, int k)
{
    int now, old, temp;
    now = p->next;
    old = a[now].next;
    if ( old == -1 ) return p;
    temp= a[old].next;
    if ( temp== -1 ) {
        if ( k==2 ) {
            a[old].next = now;
            a[now].next = -1;
            p->next = old;
            return p;
        }
        else return p;
    }
    bool f = 0;
    for ( int cnt=1; cnt<k; cnt++ ) {
        if ( cnt==k-1 && a[old].next==-1 ) f=1;
        a[old].next = now;
        now = old;
        old = temp;
        temp= a[temp].next;
    }
    Node rep = {0, p->next};
    if ( f ) a[p->next].next = -1;
    else a[p->next].next = old;
    
    p->next = now;
    
    if ( f ) return p;
    
    int cnt = 0;
    temp = old;
    
    while ( a[old].next!=-1 ) {
        old = a[old].next;
        cnt++;
        if ( cnt==k-1 ) break;
    }
    if ( cnt==k-1 ) {
        //p.next = temp;
        reverse(&a[rep.next], k);
    }
    return p;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 203,362评论 5 477
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 85,330评论 2 381
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 150,247评论 0 337
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 54,560评论 1 273
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 63,580评论 5 365
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 48,569评论 1 281
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 37,929评论 3 395
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 36,587评论 0 258
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 40,840评论 1 297
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 35,596评论 2 321
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 37,678评论 1 329
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,366评论 4 318
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 38,945评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 29,929评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,165评论 1 259
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 43,271评论 2 349
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,403评论 2 342

推荐阅读更多精彩内容

  • 百龄醉鲜竹酒选用5-10年优质茅台53度原浆酒和2岁以上优质竹子,再经活竹竹腔内经过1-3年时间的自然酿造和吸收天...
    黔西刘光兵阅读 667评论 0 0
  • 太安逸的生活总是缺乏原动力, 必须 时不时的让生活给记榔头 才会想着前行或者改变 作为老师 曾经不舍的人里面也存在...
    腊月腊日阅读 152评论 0 0
  • 今日作业 1、颜色或颜色搭配勾到我的什么? 2、若对发型、彩妆品牌选择时,抽人像卡;对款式无法抉择时,抽伴侣卡。 ...
    Bigcherry阅读 390评论 0 0
  • 信任+依赖=信赖,如果不能依赖,总会有爱这个中间变量让你:信任+爱=依赖,依赖+信任=信赖。 1 现在是北京时间2...
    墨临风阅读 292评论 0 1