hdoj1305 Immediate Decodability

题目:

Problem Description
An encoding of a set of symbols is said to be immediately decodable if no code for one symbol is the prefix of a code for another symbol. We will assume for this problem that all codes are in binary, that no two codes within a set of codes are the same, that each code has at least one bit and no more than ten bits, and that each set has at least two codes and no more than eight.
Examples: Assume an alphabet that has symbols {A, B, C, D}
The following code is immediately decodable:
A:01 B:10 C:0010 D:0000
but this one is not:
A:01 B:10 C:010 D:0000 (Note that A is a prefix of C)
Input
Write a program that accepts as input a series of groups of records from input. Each record in a group contains a collection of zeroes and ones representing a binary code for a different symbol. Each group is followed by a single separator record containing a single 9; the separator records are not part of the group. Each group is independent of other groups; the codes in one group are not related to codes in any other group (that is, each group is to be processed independently).
Output
For each group, your program should determine whether the codes in that group are immediately decodable, and should print a single output line giving the group number and stating whether the group is, or is not, immediately decodable.
Sample Input
01
10
0010
0000
9
01
10
010
0000
9
Sample Output
Set 1 is immediately decodable
Set 2 is not immediately decodable

题意:
给你一组仅有01构成的字符串集合,每组测试数据用"9"隔开。如果该组字符串中存在某些字符串是另一些字符串的前缀,则输出"Set 第几组 is not immediately decodable",否则为"Set 第几组 is immediately decodable"。

这道题是在01字符串集合中找出是否存在某些串是另一些串的前缀,可以用字典树解决。
字典树又称单词查找树,典型应用于统计,排序和保存大量的字符串等。它是利用字符串的公共前缀来节约存储空间。
字典树就类似于我们平时查英语单词,我们都是先查找第一个字母所在的范围,然后在这基础之上查找第二个字母所在的范围,依此类推。同样,字典树也与这个类似。

参考代码:

#include <iostream>
#include <algorithm>
#include <cstring>
#include <string>
#include <vector>
#include <map>
using namespace std;
const int N = 26;//编码: 0 or 1;//实际上N可以取2;
const int MAX = 8+2;//each set has at least two codes and no more than eight;

struct Trie {
    Trie *next[N];//next是表示每层有多少种类的数;
    int v;//表示一个字典树到此有多少相同前缀的数目;
};
Trie *root;
vector<string> str;

void createTrie(string str) {//创建字典树, 将该字符串里的编码加入字典树;
    int len = str.length();//该字符串的长度;
    Trie *p = root, *q;//p从根结点出发;
    for (int i = 0;i < len;++i) {
        int id = str[i] - '0';//将该字符串转换为下标;
        if (p -> next[id] == NULL) {//表明该字符没有连接到字典树;//第一个字符;
            q = new Trie;//新增结点;
            q -> v = 1;//初始v == 1;//到此有一个相同前缀;
            for (int j = 0;j < N;++j) {
                q -> next[j] = NULL;//该结点的下一个结点暂时什么也没有;
            }
            p -> next[id] = q;//根结点连接q结点;//链路表示为下标对应的编码;
            p = p -> next[id];//p值更新;
        }
        else {
            p -> next[id] -> v++;//相同前缀的数目增加;
            p = p -> next[id];//p值更新;
        }
    }
    p -> v = -1;//若为结尾, 则将v改成-1表示;
}

int findTrie(string str) {//查找;
    int len = str.length();
    Trie *p = root;
    for (int i = 0;i < len;++i) {
        int id = str[i] - '0';
        p = p -> next[id];
        if (p == NULL) {//若为空集, 表示不存在以此为前缀的串;
            return 0;
        }
        if (p -> v == -1) {//字符集中已有的串是此串的前缀;
            return -1;
        }
    }
    return -1;//此串是字符集中某串的前缀;
}

int main() {
    ios::sync_with_stdio(false);
    cin.tie(NULL);
    string s;
    int cnt = 0;
    while (cin >> s) {
        if (s != "9") {
            str.push_back(s);
        }
        else {
            bool flag = true;
            root = new Trie;//创建一个根结点;
            root -> next[0] = NULL;//初始情况, 这棵树还没有字符串;
            root -> next[1] = NULL;
            root -> v = 1;
            map<string, int> m;
            m.clear();    
            for (auto e : str) {
                int judge = findTrie(e);//查找前缀;
                if (judge == -1) {
                    ++m[e];
                }
                createTrie(e);
            }
            for (map<string, int>::iterator it = m.begin();it != m.end();++it) {
                if (it -> second > 0) {//不包括自己;
                    flag = false;
                    break;
                }
            }
            if (flag) cout << "Set " << ++cnt << " is immediately decodable" << endl;
            else cout << "Set " << ++cnt << " is not immediately decodable" << endl;     
            delete root;
            str.clear();    
        }
    }
    return 0;
}
最后编辑于
©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 206,968评论 6 482
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 88,601评论 2 382
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 153,220评论 0 344
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 55,416评论 1 279
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 64,425评论 5 374
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 49,144评论 1 285
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 38,432评论 3 401
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 37,088评论 0 261
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 43,586评论 1 300
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 36,028评论 2 325
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 38,137评论 1 334
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 33,783评论 4 324
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 39,343评论 3 307
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 30,333评论 0 19
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 31,559评论 1 262
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 45,595评论 2 355
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 42,901评论 2 345

推荐阅读更多精彩内容