hdu-1241 Oil Deposits(求子块个数)

Oil Deposits
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 3087 Accepted Submission(s): 1765

Problem Description
The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input
The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either *', representing the absence of oil, or@', representing an oil pocket.

Output
For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input
1 1

3 5
@@*
@
@@*
1 8
@@****@*
5 5
****@
@@@
@@
@@@
@
@@**@
0 0

Sample Output
0
1
2
2

#include <iostream>
using namespace std;
char dp[105][105];
int c; int k;



int bfs(int x,int y) {


    int sum=0;
    if (dp[x][y] == '@') {
        sum++;
        if (y < k) {  dp[x][y] = '*';  sum = sum + bfs(x, y + 1); }
        if (y > 0) {  dp[x][y] = '*';  sum = sum + bfs(x, y - 1); }
        if (x <c) { dp[x][y] = '*';  sum = sum + bfs(x + 1, y); }
        if (x > 0) {  dp[x][y] = '*'; sum = sum + bfs(x - 1, y); }

        if (y < k&&x < c) { dp[x][y] = '*';  sum = sum + bfs(x+1, y + 1); }//右下
        if (y < k&&x > 0) { dp[x][y] = '*';  sum = sum + bfs(x-1, y + 1); }//右上
        if (y > 0 && x < c) { dp[x][y] = '*';  sum = sum + bfs(x+1, y - 1); }//左下
        if (y > 0&&x > 0) { dp[x][y] = '*';  sum = sum + bfs(x-1, y - 1); }//左上
    
    }
    return sum;
}



void main() {
    
    while (cin >> c >> k && c&&k) {
        memset(dp, 0, sizeof(dp));
        int s1 = 0;
        for (int i = 0; i < c; i++) {
            for (int j = 0; j < k; j++) {
                cin >> dp[i][j];
            }
        }


        for (int i = 0; i < c; i++) {
            for (int j = 0; j < k; j++) {
                if (bfs(i, j) >= 1)s1++;//如果找到了连着的油矿大于0,就说明有油袋
        
            }
        }


        
        cout << s1<<endl;
    }

}




©著作权归作者所有,转载或内容合作请联系作者
  • 序言:七十年代末,一起剥皮案震惊了整个滨河市,随后出现的几起案子,更是在滨河造成了极大的恐慌,老刑警刘岩,带你破解...
    沈念sama阅读 194,088评论 5 459
  • 序言:滨河连续发生了三起死亡事件,死亡现场离奇诡异,居然都是意外死亡,警方通过查阅死者的电脑和手机,发现死者居然都...
    沈念sama阅读 81,715评论 2 371
  • 文/潘晓璐 我一进店门,熙熙楼的掌柜王于贵愁眉苦脸地迎上来,“玉大人,你说我怎么就摊上这事。” “怎么了?”我有些...
    开封第一讲书人阅读 141,361评论 0 319
  • 文/不坏的土叔 我叫张陵,是天一观的道长。 经常有香客问我,道长,这世上最难降的妖魔是什么? 我笑而不...
    开封第一讲书人阅读 52,099评论 1 263
  • 正文 为了忘掉前任,我火速办了婚礼,结果婚礼上,老公的妹妹穿的比我还像新娘。我一直安慰自己,他们只是感情好,可当我...
    茶点故事阅读 60,987评论 4 355
  • 文/花漫 我一把揭开白布。 她就那样静静地躺着,像睡着了一般。 火红的嫁衣衬着肌肤如雪。 梳的纹丝不乱的头发上,一...
    开封第一讲书人阅读 46,063评论 1 272
  • 那天,我揣着相机与录音,去河边找鬼。 笑死,一个胖子当着我的面吹牛,可吹牛的内容都是我干的。 我是一名探鬼主播,决...
    沈念sama阅读 36,486评论 3 381
  • 文/苍兰香墨 我猛地睁开眼,长吁一口气:“原来是场噩梦啊……” “哼!你这毒妇竟也来了?” 一声冷哼从身侧响起,我...
    开封第一讲书人阅读 35,175评论 0 253
  • 序言:老挝万荣一对情侣失踪,失踪者是张志新(化名)和其女友刘颖,没想到半个月后,有当地人在树林里发现了一具尸体,经...
    沈念sama阅读 39,440评论 1 290
  • 正文 独居荒郊野岭守林人离奇死亡,尸身上长有42处带血的脓包…… 初始之章·张勋 以下内容为张勋视角 年9月15日...
    茶点故事阅读 34,518评论 2 309
  • 正文 我和宋清朗相恋三年,在试婚纱的时候发现自己被绿了。 大学时的朋友给我发了我未婚夫和他白月光在一起吃饭的照片。...
    茶点故事阅读 36,305评论 1 326
  • 序言:一个原本活蹦乱跳的男人离奇死亡,死状恐怖,灵堂内的尸体忽然破棺而出,到底是诈尸还是另有隐情,我是刑警宁泽,带...
    沈念sama阅读 32,190评论 3 312
  • 正文 年R本政府宣布,位于F岛的核电站,受9级特大地震影响,放射性物质发生泄漏。R本人自食恶果不足惜,却给世界环境...
    茶点故事阅读 37,550评论 3 298
  • 文/蒙蒙 一、第九天 我趴在偏房一处隐蔽的房顶上张望。 院中可真热闹,春花似锦、人声如沸。这庄子的主人今日做“春日...
    开封第一讲书人阅读 28,880评论 0 17
  • 文/苍兰香墨 我抬头看了看天上的太阳。三九已至,却和暖如春,着一层夹袄步出监牢的瞬间,已是汗流浃背。 一阵脚步声响...
    开封第一讲书人阅读 30,152评论 1 250
  • 我被黑心中介骗来泰国打工, 没想到刚下飞机就差点儿被人妖公主榨干…… 1. 我叫王不留,地道东北人。 一个月前我还...
    沈念sama阅读 41,451评论 2 341
  • 正文 我出身青楼,却偏偏与公主长得像,于是被迫代替她去往敌国和亲。 传闻我的和亲对象是个残疾皇子,可洞房花烛夜当晚...
    茶点故事阅读 40,637评论 2 335

推荐阅读更多精彩内容

  • rljs by sennchi Timeline of History Part One The Cognitiv...
    sennchi阅读 7,251评论 0 10
  • 所谓“千里之行,始于足下”,人要走路跑步,必须先动用两脚。中国汉字中,与“足”相关的字就有:跑、跳、跃、跌、踩等一...
    大科技杂志社阅读 599评论 0 0
  • 小马找我抱怨,说书记招进来的都是些什么乱七八糟的人,企业又不缺人,还收了那么多人,一个月进了十几个,我们哪里缺人了...
    稀疏之语阅读 138评论 2 0
  • http状态码含义(来源于w3school): 状态码: 1xx: 信息响应类,表示接收到请求并且继续处理 消息:...
    测试小蚂蚁阅读 455评论 0 3