Description
There is a famous railway station in PopPush City. Country there is incredibly hilly. The stationwas built in last century. Unfortunately, funds were extremely limited that time. It was possible toestablish only a surface track. Moreover, it turned out that the station could be only a dead-end one(see picture) and due to lack of available space it could have only one track.
The local tradition is that every train arriving from the direction A continues in the directionB with coaches reorganized in some way. Assume that the train arriving from the direction A hasN ≤ 1000 coaches numbered in increasing order 1, 2, . . . , N . The chief for train reorganizations mustknow whether it is possible to marshal coaches continuing in the direction B so that their order willbe a1.a2, . . . , aN . Help him and write a program that decides whether it is possible to get the requiredorder of coaches. You can assume that single coaches can be disconnected from the train before theyenter the station and that they can move themselves until they are on the track in the direction B. Youcan also suppose that at any time there can be located as many coaches as necessary in the station.But once a coach has entered the station it cannot return to the track in the direction A and also onceit has left the station in the direction B it cannot return back to the station.
Input
The input le consists of blocks of lines. Each block except the last describes one train and possiblymore requirements for its reorganization. In the rst line of the block there is the integer N describedabove. In each of the next lines of the block there is a permutation of 1, 2, . . . , N. The last line of theblock contains just ‘0’.
The last block consists of just one line containing ‘0’.
Output
The output le contains the lines corresponding to the lines with permutations in the input le. A lineof the output le contains ‘Yes’ if it is possible to marshal the coaches in the order required on thecorresponding line of the input le. Otherwise it contains ‘No’. In addition, there is one empty line afterthe lines corresponding to one block of the input le. There is no line in the output le correspondingto the last “null” block of the input le.
Sample Input
5
1 2 3 4 5
5 4 1 2 3
0
6
6 5 4 3 2 1
0
0
Sample Output
Yes
No
Yes
理解:
这个比较简单,也是我第一次接触 栈 ,和stack关键词 , 这个可以和队列一起学习.
代码部分
#include<iostream>
#include<stack>
using namespace std;
int main()
{
stack<int>s;
stack<int>ss;
int n,n1,a[1001];
while(cin>>n)
{
if(n==0)
return 0;
while(cin>>n1)
{
if(n1==0)
break;
s.push(n1);
for(int i=1;i<n;i++)
{
cin>>n1;
s.push(n1);
}
while(!s.empty())
{
ss.push(s.top());
s.pop();
}
while(!ss.empty())
{
int k=0,ff=0,fff=0;
for(int j=0;j<n;j++)
{
a[k]=ss.top();
ss.pop();
k++;
}
if(a[0]<a[1])
{
for(int y=0;y<n-1;y++)
{
if(a[y]<a[y+1])
ff++;
if(a[y]==a[y+1])
{
ff++;
}
}
if(ff==n-1)
{
cout<<"Yes\n";
}
if(ff!=n-1)
{
cout<<"No\n";
}
}
if(a[0]>=a[1])
{
for(int y=0;y<n-1;y++)
{
if(a[y]>a[y+1])
fff++;
if(a[y]==a[y+1])
{
fff++;
}
}
if(fff==n-1)
{
cout<<"Yes\n";
}
if(fff!=n-1)
cout<<"No\n";
}
}
}cout<<endl;
}
return 0;
}