Pat1002 A+B for Polynomials(25)
This time, you are supposed to find A+B where A and B are two polynomials.
Input
Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.
Output
For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.
Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output
3 2 1.5 1 2.9 0 3.2
说一下遇到的问题:
- 格式错误,要求跟输入一样,浮点书表留一位小数,最后不能由空格
- 没有考虑到如果两个多项式相加,会出现系数为0的情况,此时不再记录(多虑的是demo分明由0输出了么,但是它是指数不是系数)
- 数据的类型,一定尽量开始就合适
我的代码
#include <map>
#include <iostream>
#include<iterator>
#include <iomanip>
using namespace std;
map<int,double> da;
int main()
{
int size;
int tmp1;
double tmp2;
cin>>size;
for(int i=0;i<size;++i)
{
cin>>tmp1;
cin>>tmp2;
da[tmp1]+=tmp2;
}
cin>>size;
for(int i=0;i<size;++i)
{
cin>>tmp1;
cin>>tmp2;
da[tmp1]+=tmp2;
if(da[tmp1]==0)
da.erase(tmp1);
}
cout<<da.size();
for(map<int,double>::reverse_iterator s=da.rbegin();s!=da.rend();++s)
{
cout<<fixed<<setprecision(1);
cout<<" "<<s->first<<" "<<s->second;
}
cout<<endl;
return 0;
}