什么是欧拉路径?
欧拉路径是无向连通图中的一条路径,该路径经过图的每一条边且仅经过一次。如果路径起点和终点相同,则称“欧拉回路”。具有欧拉回路的图称“欧拉图”。
如何判断图中是否存在欧拉路径?
由欧拉路径的定义可知,若图中存在欧拉路径,则该图必是一个连通图 (1),其次,图中度数为奇数的点的个数必须为0或2 (2),若度数为奇数的点的个数为0则是欧拉回路,若个数为2则是非欧拉回路的欧拉路径在此题中称为"Semi-Eulerian",其余情况均不是欧拉路径。
原题
1126 Eulerian Path (25 分)
In graph theory, an Eulerian path is a path in a graph which visits every edge exactly once. Similarly, an Eulerian circuit is an Eulerian path which starts and ends on the same vertex. They were first discussed by Leonhard Euler while solving the famous Seven Bridges of Konigsberg problem in 1736. It has been proven that connected graphs with all vertices of even degree have an Eulerian circuit, and such graphs are called Eulerian. If there are exactly two vertices of odd degree, all Eulerian paths start at one of them and end at the other. A graph that has an Eulerian path but not an Eulerian circuit is called semi-Eulerian. (Cited from https://en.wikipedia.org/wiki/Eulerian_path)
Given an undirected graph, you are supposed to tell if it is Eulerian, semi-Eulerian, or non-Eulerian.
Input Specification:
Each input file contains one test case. Each case starts with a line containing 2 numbers N (≤ 500), and M, which are the total number of vertices, and the number of edges, respectively. Then M lines follow, each describes an edge by giving the two ends of the edge (the vertices are numbered from 1 to N).
Output Specification:
For each test case, first print in a line the degrees of the vertices in ascending order of their indices. Then in the next line print your conclusion about the graph -- either Eulerian, Semi-Eulerian, or Non-Eulerian. Note that all the numbers in the first line must be separated by exactly 1 space, and there must be no extra space at the beginning or the end of the line.
Sample Input 1:
7 12
5 7
1 2
1 3
2 3
2 4
3 4
5 2
7 6
6 3
4 5
6 4
5 6
Sample Output 1:
2 4 4 4 4 4 2
Eulerian
Sample Input 2:
6 10
1 2
1 3
2 3
2 4
3 4
5 2
6 3
4 5
6 4
5 6
Sample Output 2:
2 4 4 4 3 3
Semi-Eulerian
Sample Input 3:
5 8
1 2
2 5
5 4
4 1
1 3
3 2
3 4
5 3
Sample Output 3:
3 3 4 3 3
Non-Eulerian
AC代码(C++)
#include <iostream>
#include <vector>
using namespace std;
int N, M, v1, v2, visited[505], degrees[505], judge = 1, cnt;
vector<int>graph[505];
void dfs(int d){
visited[d] = 1;
for(int i = 0; i < graph[d].size(); i++){
if(!visited[graph[d][i]])dfs(graph[d][i]);
}
}
int main(){
scanf("%d%d", &N, &M);
for(int i = 0; i < M; i++){
scanf("%d%d", &v1, &v2);
graph[v1].push_back(v2);
graph[v2].push_back(v1);
degrees[v1]++;
degrees[v2]++;
}
dfs(1);
for(int i = 1; i <= N; i++)
if(!visited[i]){
judge = 0;
break;
}
for(int i = 1; i <= N; i++)
if(i == 1)printf("%d", degrees[i]);
else printf(" %d", degrees[i]);
printf("\n");
if(judge){
for(int i = 1; i <= N; i++)
if(degrees[i] % 2 == 1)cnt++;
if(cnt == 0)printf("Eulerian\n");
else if(cnt == 2) printf("Semi-Eulerian\n");
else printf("Non-Eulerian\n");
}else printf("Non-Eulerian\n");
return 0;
}