问题描述
给定两棵树T1和T2。如果T1可以通过若干次左右孩子互换就变成T2,则我们称两棵树是“同构”的。例如图1给出的两棵树就是同构的,因为我们把其中一棵树的结点A、B、G的左右孩子互换后,就得到另外一棵树。而图2就不是同构的。
图1
图2
现给定两棵树,请你判断它们是否是同构的。
输入格式:
输入给出2棵二叉树树的信息。对于每棵树,首先在一行中给出一个非负整数N (≤10),即该树的结点数(此时假设结点从0到N−1编号);随后N行,第i行对应编号第i个结点,给出该结点中存储的1个英文大写字母、其左孩子结点的编号、右孩子结点的编号。如果孩子结点为空,则在相应位置上给出“-”。给出的数据间用一个空格分隔。注意:题目保证每个结点中存储的字母是不同的。
输出格式:
如果两棵树是同构的,输出“Yes”,否则输出“No”。
输入样例1(对应图1):
8
A 1 2
B 3 4
C 5 -
D - -
E 6 -
G 7 -
F - -
H - -
8
G - 4
B 7 6
F - -
A 5 1
H - -
C 0 -
D - -
E 2 -
输出样例1:
Yes
输入样例2(对应图2):
8
B 5 7
F - -
A 0 3
C 6 -
H - -
D - -
G 4 -
E 1 -
8
D 6 -
B 5 -
E - -
H - -
C 0 2
G - 3
F - -
A 1 4
输出样例2:
No
解决思路
分别找到两棵树的根
利用层序遍历即可得出答案,我们遍历得出同样的顺序即表明是同构的树
根据题意的同构,在左右节点相反时,互换左右节点push顺序
我们只需修改List Leaves中的一些函数即可
Some Detail Of Function
int printResult(Pnode p, Pnode p1, int root, int root1):需要提及一点,一开始需要判断两个根是否一致,才能往下比较
Notice:注意空树的特殊情况!
Code
#include<stdio.h>
#include<malloc.h>
#define SIZE 15
typedef struct node {
int left;
int right;
int isRoot;
char symbol;
}Node, *Pnode;
typedef struct queue
{
Pnode queue[SIZE + 1];
int front;
int rear;
}Queue, *Pqueue;
Pqueue createQueue(void);
Pnode createList(int length);
int findRoot(Pnode node, int lenght);
int printResult(Pnode p, Pnode p1, int root, int root1);
int getValue(void);
Pnode pop(Pqueue queue);
void push(Pqueue p, Pnode node);
int isEmpty(Pqueue p);
int main(void) {
int length;
int length1;
int root;
int root1;
scanf("%d", &length);
Pnode array = createList(length);
scanf("%d", &length1);
Pnode array1 = createList(length1);
if (length != length1) {
printf("No");
return 0;
}
else if (length == 0) {
printf("Yes");
return 0;
}
root = findRoot(array, length);
root1 = findRoot(array1, length1);
if (printResult(array, array1, root, root1))
printf("Yes");
else
printf("No");
return 0;
}
Pnode createList(int length) {
Pnode array = (Pnode)malloc(sizeof(Node)*length);
char right;
char left;
getchar();
for (int i = 0; i < length; i++) {
scanf("%c ", &array[i].symbol);
array[i].isRoot = 1;
array[i].left = getValue();
array[i].right = getValue();
}
return array;
}
Pqueue createQueue(void) {
Pqueue p = 0;
p = (Pqueue)malloc(sizeof(Queue));
p->front = p->rear = 0;
return p;
}
int findRoot(Pnode node, int lenght) {
for (int i = 0; i < lenght; i++) {
if (node[i].left != -1)
node[node[i].left].isRoot = 0;
if (node[i].right != -1)
node[node[i].right].isRoot = 0;
}
for (int j = 0; j < lenght; j++) {
if (node[j].isRoot == 1)
return j;
}
return 0;
}
Pnode pop(Pqueue queue) {
Pnode p = queue->queue[queue->rear++];
return p;
}
int getValue(void) {
int count = 0;
char value;
char temp[5];
for (; (value = getchar()) != ' ' && value != '\n';) {
temp[count++] = value;
}
if (count == 2) {
return 10;
}
else if (temp[0] == '-') {
return -1;
}
else {
return temp[0] - '0';
}
}
int isEmpty(Pqueue p) {
if (p->front == p->rear)
return 1;
return 0;
}
void push(Pqueue p, Pnode node) {
p->queue[p->front++] = node;
}
int printResult(Pnode p, Pnode p1, int root, int root1) {
Pqueue queue = createQueue();
Pqueue queue1 = createQueue();
Pnode check;
Pnode check1;
if (p[root].symbol != p1[root1].symbol) {
return 0;
}
push(queue, &p[root]);
push(queue1, &p1[root1]);
for (; !isEmpty(queue);) {
check = pop(queue);
check1 = pop(queue1);
if (p[check->left].symbol == p1[check1->left].symbol && p[check->right].symbol == p1[check1->right].symbol) {
if (check->left != -1) {
push(queue, &p[check->left]);
push(queue1, &p1[check1->left]);
}
if (check->right != -1) {
push(queue, &p[check->right]);
push(queue1, &p1[check1->right]);
}
}
else if (p[check->left].symbol == p1[check1->right].symbol && p[check->right].symbol == p1[check1->left].symbol) {
if (check->left != -1) {
push(queue, &p[check->left]);
push(queue1, &p1[check1->right]);
}
if (check->right != -1) {
push(queue, &p[check->right]);
push(queue1, &p1[check1->left]);
}
}
else {
return 0;
}
}
return 1;
}
Summary
这题总体较为简单,明白层序遍历便可以轻松答出,唯一需要注意的便是在copy一些重复代码时,记得要修改!!!